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6
Part Modeling

6.1  Introduction

Part modeling is one of the most time-consuming jobs in computer-aided 
design (CAD). Part modeling or solid modeling happens sequentially after 
sketching. A component that can be manufactured from a single work piece 
without any assembly operation can be termed part. Any intensive proper-
ties of any part will always be the same across the geometry. No engineering 
component can be made without a part. Therefore, part modeling is one of 
the essential steps before continuing to the creation of any assembly.

It is obvious that any part creation consists of all the operations that pro-
vide the shape and size of the part.

Parts can be created or modeled with two approaches: primitives and 
 features. In the primitive approach, the basic solid shapes like blocks, 
 cylinders, cones, spheres, and so forth are available via predesigned defin-
able templates. The final model is created by Boolean operation like addition 
or subtraction of primitives to prepare the final solid model. In the feature 
approach, the solid is directly created by generating the sections. Feature-
based modeling is the most used nowadays in most of the modern CAD 
software like PRO/E, CATIA, Solid Works, Unigraphics, and so forth. Since 
feature-based modeling is the most used in most of the CAD industry in 
mechanical component design, it is only discussed in the latter portion of 
this book.

Obviously a 3-D solid model can be created by one or many sets of combi-
nations of features. When creating any operation, CAD does not understand 
the practical limit of creating the operation, unless any warning limit system 
is otherwise introduced. For example, a too-narrow slot with excessive depth 
can be practically difficult; however, it is easy in CAD. Therefore, one may 
end up creating a CAD model that may not be possible or that may be too 
expensive to manufacture. It is always advisable to create the component in 
conjunction with the actual manufacturing sequence whenever possible. For 
example, a plate with a hole is displayed in Figure 6.1. The displayed model can 
be generated by sketching a rectangle with a hole followed by an extrusion 
command or by creating a solid block followed by a hole operation. When 
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102 Computer-Aided Design

manufacturing methods are considered, in the former method, the compo-
nent may be molded to create the model, and in the other method, a simple 
hole operation is required in some metal piece that may be cut from a strip. 
It is obvious that the former method is more expensive.

So it is recommended to use the features sequentially with the manufactur-
ing processes that may be involved in the production of the part in real life.

The following are the advantages to creating a model as per practical man-
ufacturing operations:

 1. Designers will never have the problem of practical component 
creation.

 2. The creation method of the component or part can be shown step by 
step for understanding the manufacturing procedure.

 3. The model in various stages can be used for different purposes, if 
the final part or component is modeled by the practical creation 
method sequence. For example, if a part is created from casting and 
followed by machining, the part without the machining operation 
can be used for pattern creation drawing.

 4. It helps for optimization among different operation sequences of cre-
ation of the part.

However, there are some disadvantages, which designers sometimes ignore, 
to creating parts as per manufacturing sequences. They are as follows:

 1. When creating a mechanism or complex assembly design, designers 
need to see the usefulness of various shaped parts for which follow-
ing practical operation sequences is not viable before finalizing the 
component or part.

 2. It requires more time; therefore, for simple parts, designers often 
ignore practical sequences.

 3. Sometimes, creating a part with the actual operation sequence may 
be difficult and is not advised.

FIGURE 6.1
Example of a plate with a hole.
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Nowadays, most parts are created using feature-based approaches. There-
fore, it is essential to know about the various available features in CAD.

6.2  Feature

In CAD, a feature can be defined as an object or entity or a created region 
capable of possessing many properties but may or may not have an effect on 
mass properties of the model. Every feature can also include its own proper-
ties like name, parameters, and so forth. The following features are essential 
in the creation of parts.

6.2.1  Datum Features

Datum features are nonsolid features with null mass properties. They often 
are required to create the solid model and/or act as reference geometry.

• Plane: As described earlier, planes are imaginary flat surfaces, used 
as a sketch plane or reference geometry. Planes can be created by 
many methods, the objective being to select a sufficient entity to sat-
isfy the equation of a plane.
• Three-point plane: The equation of a plane through a given point 

can be given by ax + by + cz + d = 0. If the places pass through a 
point (x1,y1,z1), we have ax1 + by1 + cz1 + d = 0.

 Subtracting these equations from each other, we get

 a(x − x1) + b(y − y1) + c(z − z1) + d = 0. (6.1)

 Let there be three points whose coordinates are as follows: 
M(4,3,5), N(8,2,9), and O(10,−4,8).

 Hence, the equation of the plane becomes

 a(x − 4) + b(y − 3) + c(z − 5) = 0. (6.2)

 If the plane passes through the other points, then the equation 
becomes a(8 − 4) + b(2 − 3)+ c(9 − 5) = 0 and a(10 − 4) + b(−4 + 3) + 
c(8 − 5) = 0, that is, 4a − b + 4c = 0 and 6a − b + 3c = 0.

 Solving these equations, we get a
b c

= =
12 6

.

 Substituting, these values to Equation 6.2, we get

 (x − 4) + 12(y − 3) + 6(z − 5) = 0

 or x + 12y + 6z − 70 = 0, which is the required equation of the plane.
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• Parallel planes: If there are two planes and the equations of the 
planes are

 ax + by + cz + d = 0

 and

 a1x + b1y + c1z + d1 = 0,

 if the planes are parallel, their normals are also parallel; hence, 
the condition would be

 
a
a

b
b

c
c1 1 1

= = . 

 Hence, the equation of any plane parallel to the plane

 ax + by + cz + d = 0 

 will be

 ax + by + cz + k = 0 

 where k is the constant.
  For example, if the equation of a plane is

 5x + 4y + 9z + 10 = 0, 

 the equation of parallel plane to this plane passing through point 
(−9,−10,−5) would be as follows:

 5x + 4y + 9z + k = 0 

 5(−9) + 4(−10) + 9(−4) + k = 0 

 −4 − 40 − 36 + k = 0 

 k = 80 

 Hence, the required equation would be

 5x + 4y + 9z + 80 = 0. 
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 Perpendicular to a straight line and on a point: It is often required in 
CAD to draw a plane that is perpendicular to a line and passing 
through a point. If the line is joining two points (5,8,10) and (2,7,9) 
and the passing point of the plane is (1,−5,−9), then we know the 
equation of the plane be

 a(x − 1) + b(y + 5) + c(z + 9) = 0. 

 The direction ratios of the joining line would be 5−2,8−7,10−9 
or 3,1,1.

  Hence, the required equation of the plane would be

 3(x − 1) + 1(y + 5) + 1(z + 9) = 0 

 3x + y + z + 11 = 0 

• Lies on an axis and a point: A plane can be defined such that it is 
lying on an axis and a point and the point must not lie on the 
axis. When the plane is lying on the axis, all the points lying on 
the axis are lying on the plane. Hence, if we consider any two 
points lying on the axis, the equation can be derived easily by 
considering three-point-plane equations.

• Rotated through an axis with regard to a plane or surface:
 Let the equation of a plane be 4x + 5y + 9z + 2 = 0.

• Axis: An axis is an imaginary line that can be used as a reference 
entity for construction of a sketch or other entity. Similar to a plane, 
to create an axis, the selection shall be sufficient to satisfy the equa-
tion of a straight line.
• Selecting two points:

 The equation of a line in its symmetrical form is
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−

=
−

=
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. (6.3)

 If the line passes two points (x1,y1,z1) and (x2,y2,z2), the direction 
ratios become (x2 − x1), (y2 − y1), (z2 − z1), and the line is passing 
through the point x1,y1,z1.

  Hence, the equation of the line becomes
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• Selecting two intersecting planes: The easiest way to create an axis 
in CAD is selecting two planes so that the axis is created in the 
intersection of two planes, say,

 ax + by + cz + d = 0 and a1x + b1y + c1z + d1 = 0,

 which together are called the equation of a line in general form.
  Perpendicular to a plane and passing through a point: Let us say the 

equation of a plane is 4x + 5y + z + 10 = 0, and the line is piercing 
the plane at a point (2,3,−33). Hence, the direction ratio normal to 
the plane is (4,5,1). Hence, the equation of the line is

 
x y z+

=
+

=
−2

4
3

5
33

1
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• Parallel to a line and passing through a point.
• Point: Points can be created by selecting a sufficient entity to satisfy 

single coordinates. The common methods of creation of points are 
as follows:
• Intersection of three planes: If two planes are intersecting, a line is 

formed, and if a third plane is intersecting that line, the point is 
found.

  Example: Find the coordinate of a point where three planes are 
intersecting whose equations are as follows:

 5x + 1y + 2z + 10 = 0

 7x − 4y + 9z + 1 = 0

 2x + 3y + z − 11 = 0

 Solving the equations, we get the coordinates of the point as 
(−246/43, 410/43, 287/43).

• Intersection of two axes.
• Dimensional offset from an existing point.
• Sketched points.

• Coordinate system: A coordinate system can be created by selecting 
 similar references with points, except additional selection may require 
defining the direction of the axes. A coordinate system can be defined 
by one of the following methods:
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• Offsetting from a coordinate system
• Selecting three planes and directional references
• Selecting a point and directional references

6.2.2  Extrude

Extrusion is a method of creation of a protruded region in a particular direc-
tion. Some CAD software provides extrusion to a particular definable direc-
tion vector, whereas much CAD software provides an option only for creation 
in a normal direction of the sketch plane. Extrusion can be used for addition or 
subtraction of materials. The following options are available while extruding:

 1. Blind extrusion: It is the extrusion process with definite value to the 
normal direction. This is the most used in modeling. A user has to 
calculate the values of extrusion each time when creating any extru-
sion with blind values.

 2. Extrude up to surface or selected feature: When the need is such that 
the depth of extrusion is derived by another surface that is available 
for selection, this feature can be used. This system is particularly 
useful in creation of a parametric model where the depth of sev-
eral features of common depth can be linked to a common datum; 
hence, the selection up to the surface or plane is made so that when 
the datum moves, it changes the depth of all features. However, it is 
to be kept in mind that the selection entity for this feature must be 
available; otherwise, the entire feature related to the selection will 
miss the references, and feature failure can occur.

 3. Mid plane extrusion: Mid plane extrusions create the depth of the part 
symmetrical to both sides of the sketch plane.

 a. Advantages:
 i. This creates symmetrical depth of the feature across the 

sketch plane.
 ii. The sketch plane is readily available as the mid plane if refer-

ence is required for assembly or measurement and so forth.
 b. Disadvantages:
 i. It may be difficult to understand the sides of the feature if 

the part is symmetrical about the sketch plane. Therefore, if 
the part is placed several times in an assembly with different 
 orientations, any addition of the feature can appear differ-
ent or opposite in the assembly for different instances of the 
same component.

 4. Extrude with draft: This feature is available in some CAD software 
and is useful to model taper parts especially for casting models where 
a draft is necessary.
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Hands-On Exercise, Example 6.1: Create a Block of 
Dimension 500 × 500 × 200 with Blind Depth and Mid 
Plane Option (Software Used: Creo Parametric)

Steps:
Assume a part file is created with three default planes, RIGHT, TOP, 

and FRONT.

• Select the Extrude feature from the ribbon at the top. Clicking 
on the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the Placement tab, and select Define sketch. A pre-
defined sketch also can be selected in this box. However, as no 
predefined sketch is available now, click on Define.

• As Define is clicked, a small toolbox appears for placement of 
the sketch. Select the top plane for the sketch. The references for 
orientation (deciding orientation of sketch plane) may need to 
be selected if perpendicular planes of the sketch plane are not 
available. Once the references are available, click on the Sketch 
button to define the sketch.

• The references to locate the sketch should have been automati-
cally created; however, if the references are not taken, click on 
the Reference icon at the top left corner and select the refer-
ences. Perpendicular planes automatically may be taken as 
references. However, axes, points, or other geometries also can 
be taken as references. For our case, select the right and front 
planes for references not being automatically taken.

• Select Axis from the sketch ribbon to keep the original sketch 
symmetrical to the axis. Draw one vertical and one horizontal 
axis along the references of the right and front planes.

• Once the axes are drawn, select Rectangle from the sketch rib-
bon, and click on the top left quadrant to locate the left corner. 
Then click again at the right bottom quadrant to an approxi-
mate distance such that it can form a symmetrical rectangle 
with respect to the axes. Automatically, the symmetrical con-
straint is taken by the system. This practice saves time for creat-
ing constraints.

• Two weak dimensions may be displayed if the weak dimension 
display is activated. Enter the dimension 500 to both fields by 
double-clicking the weak dimensions. Select OK.

• When creating any sketch, make sure there is no weak dimen-
sion. This ensures that sections or sketches are not overlooked.

• Once finished with the sketch, enter the value of 200 in the 
blind field. The flip option for changing the direction of extru-
sion is beside the blind depth value box.

• The mid plane option also can be selected via the drop-down 
menu beside Blind.
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• The top plane will act as a symmetrical mid plane if the mid 
plane option is selected.

• Click OK to finally create the feature.
• Save the file.

Hands-On Exercise, Example 6.2: Use of the Up to the 
Selection Option (Software Used: Creo Parametric)

Steps:
Assume a part file is created with three default planes, RIGHT, TOP, 

and FRONT.

• Select the plane creation option in the Model tab of the ribbon 
interface.

• Select the top plane as reference and create a plane by offset 
value of 500 upward from the top plane. The plane will be auto-
matically named DTM1.

• Select Axis creation of option from the Model tab of the ribbon 
interface.

• Create an axis by selecting the right plane and DTM1 plane. 
The axis will be named A_1.

• Select the plane creation option again. Create a plane by select-
ing the axis A_1 and plane DTM1. The plane shall be at an angle 
of 45° to the plane DTM1.

• Select the Extrude feature from the ribbon at the top. Clicking 
on the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the Placement tab, and select Define sketch. A pre-
defined sketch also can be selected in this box. However, as no 
predefined sketch is available now, click on Define.

• As Define is clicked, a small toolbox appears for placement of 
the sketch. Select the top plane for the sketch. The references for 
orientation (deciding orientation of sketch plane) may need to 
be selected if perpendicular planes of the sketch plane are not 
available. Once the references are available, click on the Sketch 
button to define the sketch.

• The references to locate the sketch should have been automati-
cally created; however, if the references are not taken, click on 
the Reference icon at the top left corner and select the refer-
ences. Perpendicular planes automatically may be taken as 
references. However, axes, points, or other geometries also can 
be taken as references. For our case, select the right and front 
planes for references not being automatically taken.

• Select Axis from the sketch ribbon to keep the original sketch 
symmetrical to the axis. Draw one vertical and one horizontal 
axis along the references of the right and front planes.
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• Once the axes are drawn, select Rectangle from the sketch rib-
bon, and click on the top left quadrant to locate the left corner. 
Then click again at the right bottom quadrant to an approxi-
mate distance such that it can form a symmetrical rectangle 
about the axes. Automatically, the symmetrical constraint 
is taken by the system. This practice saves time for creating 
constraints.

• Two weak dimensions may be displayed if the weak dimension 
display is activated. Enter the dimension 500 to both fields by 
double-clicking the weak dimensions. Select OK.

• When creating any sketch, make sure there is no weak dimen-
sion. This ensures that sections or sketches are not overlooked.

• Once finished with the sketch, select the option To-selected 
from the drop-down menu beside the blind depth field.

• This will allow the selecting of any reference geometry to 
calculate the depth of the feature. Select DTM1; the extrusion 
depth of 500 mm will be displayed.

• Select the plane DTM2 instead of DTM1 in the To-selected 
field. The feature will be tapered at the extruded end. This will 
allow creation of a feature up to a surface with the end shape as 
allowed by the surface.

• The To-selected option is also used to create many features hav-
ing depth to common reference.

• A most effective example of the To-selected option is described. 
Creation of this example needs knowledge of top–down assem-
bly creation; however, it is shown here for practical application 
of the To-selected option.

• Create an assembly from the Find new menu and the template 
mmns_asm_design.

• The assembly will contain three planes, ASM_RIGHT, ASM_
TOP, and ASM_FRONT.

• Rename the top plane as FFL_0m. This signifies the plane at a 
finished floor level at 0 m.

• Create another plane by offsetting the plane FFL_0m to 4500 mm. 
This signifies a level elevation of 4.5 m. Rename the plane as 
concrete_top_4500.

• Select Create a component in assembly mode, and create a part 
named column1.

• Select the option Locate default datums and click OK. Select the 
assembly planes ASM_Right, FFL_0m, and ASM_FRONT. The 
part column1 will be automatically activated; select Extrude 
and create a square of 500 × 500. Click OK. When prompted 
for depth, select the Up to select option and select the plane 
concrete_top_4500. Click OK to create the feature.

• Activate the main assembly by right-clicking on it and select 
Activate.

• Create another column, column2, using the same procedure. 
Make column2 a distance of 5000 mm from column1 and with 
dimensions of 1000 × 1000 mm.
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• Create another column, column3, using the same procedure. 
Make column3 a distance of 10,000 mm from column1 and with 
dimensions of 2000 × 2000 mm.

• All the columns must be created with the To-selected option 
and by selecting the plane concrete_top_4500 plane.

• Now all the three columns are of the same height. Right-click 
on the plane concrete_top_4500 and select Edit. Change the 
value to 10,000 mm and click on Regenerate. All the columns 
will be regenerated to 10,000 mm length.

6.2.3  Revolve

Revolve is a method of generating a region by rotating a section around 
an axis. Any kind of axisymmetric section is suitable for a revolve opera-
tion. A solid shape generated from a revolve operation may also be gener-
ated from an extrude operation; however, an extrude operation may not be 
logical and may be time consuming when the section can be generated by 
revolving about a single axis. The choice is to be made logically through 
a manufacturing sequence. If the section is such that it is generated from 
such a rotating manufacturing procedure, the model should be made by the 
revolve feature.

Axis of revolution: The essential entity in the revolve feature is axis of rota-
tion. Axis of rotation should be drawn or selected first when creating rotat-
ing sections.

Similar to the extrude feature, the revolve feature also has the same options 
like blind revolving through a user-entered angle with one or both direc-
tions or the To-selected option.

Hands-On Exercise, Example 6.3: Basic Revolve Option 
(Software Used: Creo Parametric)

Steps:
Assume a part file is created with three default planes, RIGHT, TOP, 

and FRONT.

• Select the Revolve feature from the ribbon at the top. Clicking 
on the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the Placement tab, and select Define sketch. A pre-
defined sketch also can be selected in this box. However, as no 
predefined sketch is available now, click on Define.

• As Define is clicked, a small toolbox appears for placement of 
the sketch. Select the front plane for the sketch. The references 
for orientation (deciding orientation of sketch plane) may need 
to be selected if perpendicular planes of the sketch plane are 
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not available. Once the references are available, click on the 
Sketch button to define the sketch.

• The references to locate the sketch should have been automati-
cally created; however, if the references are not taken, click on 
the Reference icon at the top left corner and select the refer-
ences. Perpendicular planes automatically may be taken as ref-
erences. However, axes, points, or other geometries also can be 
taken as references. For our case, select the right and top planes 
for references not being automatically taken.

• Select Axis from the sketch ribbon, and draw a vertical axis.
• Once the axes are drawn, select Rectangle from the sketch rib-

bon, and make the section.
• When creating any sketch, make sure there is no weak dimen-

sion. This ensures that sections or sketches are not overlooked.
• Once finished with the sketch, enter the value of 360 in the 

blind field. The flip option for changing the direction of extru-
sion is beside the blind depth value box.

• The mid plane option also can be selected via the drop-down 
menu beside Blind.

• Click OK to finally create the feature.
• Create a plane offset of the right plane by a value of 300 mm.
• Create an axis by selecting the front and newly created plane 

DTM1.
• Select the revolve feature in the model tree and drag it to the 

bottom after the newly created axis.
• This will make the axis available for selection when editing the 

revolve feature.
• Select the revolve feature, right-click, and select Edit definition.
• Click on the Placement tab and select the newly created axis in 

the axis selection field.
• The section will be now revolved about the newly created axis.
• Set a value for rotational degree, and click OK to create the 

feature.
• Save the file.

Hands-On Exercise, Example 6.3a: Revolving a Machining Section

Steps:
Assume a part file is created with three default planes, RIGHT, TOP, 

and FRONT.

• Select the Revolve feature from the ribbon at the top. Clicking 
on the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the Placement tab, and select Define sketch. A pre-
defined sketch also can be selected in this box. However, as no 
predefined sketch is available now, click on Define.
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• As Define is clicked, a small toolbox appears for placement of 
the sketch. Select the front plane for the sketch. The references 
for orientation (deciding orientation of sketch plane) may need 
to be selected if perpendicular planes of the sketch plane are 
not available. Once the references are available, click on the 
Sketch button to define the sketch.

• The references to locate the sketch should have been automati-
cally created; however, if the references are not taken, click on 
the Reference icon at the top left corner and select the refer-
ences. Perpendicular planes automatically may be taken as ref-
erences. However, axes, points, or other geometries also can be 
taken as references. For our case, select the right and top planes 
for references not being automatically taken.

• Select Axis from the sketch ribbon, and draw a vertical axis.
• Create the section of a rectangle.
• When creating any sketch, make sure there is no weak dimen-

sion. This ensures that sections or sketches are not overlooked.
• Once finished with the sketch, enter the value of 360 in the 

blind field. The flip option for changing the direction of extru-
sion is beside the blind depth value box.

• The mid plane option also can be selected via the drop-down 
menu beside Blind.

• Click OK to finally create the feature.
• Save the file.

Hands-On Exercise, Example 6.4: Creating a Flywheel 
(Software Used: Creo Parametric; Refer to Figure 6.2)

Steps:

• Create a part file and rename it as Flywheel. (Other names may 
be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The flywheel as shown in Figure 6.2 is to be created.
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• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.3.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click on OK to create the revolve feature.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.

FIGURE 6.2
3-D flywheel created in CAD.
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FIGURE 6.3
Constructional sketch of a flywheel.
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• Select the middle flat surface as the sketch plane.
• The front plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as shown in Figure 6.4.
• Click OK to create and exit the sketch.
• Select the Through all option in the field of depth selection.
• Select the option Material removal feature.
• Flip the orientation toward the body of the revolved feature if 

required.
• Click on OK to create the extrusion cut.
• Click on Round feature from the Model tab of the ribbon 

interface.
• Set the value of fillet to 10 mm.
• Select all four internal edges of the newly created feature.
• Click OK to create the feature.
• Select the newly created extrusion cut and round from the 

model tree by pressing the Control key.
• Right-click and select Group to make the feature group.
• Select the newly created group in the model tree.
• Right-click and select Pattern.
• Select Axis in the Type of pattern selection field.
• Select the central axis.
• Enter the quantity 8 for patterned feature.
• Select the option to make the pattern equally spaced within 

360°.
• Click OK to create the patterned feature.
• Click on the auto round feature from the Model tab of the rib-

bon interface.
• Set the value of fillet to 3 mm.
• Select the shat bore edges that are not required to be round.
• Click OK to create the feature.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the flat shaft face as the sketch plane.
• The front plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a square of 5 × 5 mm placing the bottom corners at the top 

side of the inside circular edge.
• Click OK to create and exit the sketch.
• Select the Through all option in the field of depth selection.
• Select the option Material removal feature.
• Flip the orientation toward the body of the revolved feature if 

required.
• Click on OK to create the extrusion cut.
• Save and exit the file.
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6.2.4  Sweep

Sweep is an operation of generating a region by moving a section through 
a curved path. Curve paths are called trajectories. A guide curve can also 
be straight or curved. A straight guide curve will result in a model shape 
similar to extrusion. A sweep can be of constant section or variable section.

Hands-On Exercise, Example 6.5: Creating a Handle and T-Slot

Steps:
Assume a part file is created with three default planes, RIGHT, TOP, 

and FRONT.

• Select the Sketch feature from the ribbon at the top. Clicking on 
the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the Placement tab, and select Define sketch. A pre-
defined sketch also can be selected in this box. However, as no 
predefined sketch is available now, click on Define.

• As Define is clicked, a small toolbox appears for placement of 
the sketch. Select the front plane for the sketch. The references 
for orientation (deciding orientation of sketch plane) may need 
to be selected if perpendicular planes of the sketch plane are 
not available. Once the references are available, click on the 
Sketch button to define the sketch.

• The references to locate the sketch should have been automati-
cally created; however, if the references are not taken, click on 
the Reference icon at the top left corner and select the refer-
ences. Perpendicular planes automatically may be taken as ref-
erences. However, axes, points, or other geometries also can be 
taken as references. For our case, select the right and top planes 
for references not being automatically taken.

• Select Axis from the sketch ribbon to keep the original sketch 
symmetrical to the axis. Draw one vertical and one horizontal 
axis along the references of the right and front planes.

• Create the sketch as displayed in Figure 6.4a.
• When creating any sketch, make sure there is no weak dimen-

sion. This ensures that sections or sketches are not overlooked.
• Click OK.
• Select the Sweep feature from the ribbon at the top. Clicking on 

the feature opens the selection box for all other options.
• Select the previously created sketch as a trajectory in the 

Reference tab.
• Select the Sketch button in the ribbon interface.
• Draw a circle of diameter 10 mm placing the center of the circle 

at the cross section of the references.
• Click OK to finally create the feature.
• Save the file.
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T-SLOT PROFILE

Assume a part file is created with three default planes, RIGHT, TOP, 
and FRONT.

• Select the Extrude feature from the ribbon at the top. Clicking 
on the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the Placement tab, and select Define sketch. A pre-
defined sketch also can be selected in this box. However, as no 
predefined sketch is available now, click on Define.

• As Define is clicked, a small toolbox appears for placement of 
the sketch. Select the top plane for the sketch. The references for 
orientation (deciding orientation of sketch plane) may need to 
be selected if perpendicular planes of the sketch plane are not 
available. Once the references are available, click on the Sketch 
button to define the sketch.

• The references to locate the sketch should have been automati-
cally created; however, if the references are not taken, click on 
the Reference icon at the top left corner and select the refer-
ences. Perpendicular planes automatically may be taken as 
references. However, axes, points, or other geometries also can 
be taken as references. For our case, select the right and front 
planes for references not being automatically taken.

• Select Axis from the sketch ribbon to keep the original sketch 
symmetrical to the axis. Draw one vertical and one horizontal 
axis along the references of the right and front planes.

• Once the axes are drawn, select Rectangle from the sketch rib-
bon, and click on the top left quadrant to locate the left corner. 
Then click again at the right bottom quadrant to an approxi-
mate distance such that it can form a symmetrical rectangle 
with respect to the axes. Automatically, the symmetrical con-
straint is taken by the system. This practice saves time for creat-
ing constraints.

• Two weak dimensions may be displayed if the weak dimension 
display is activated. Enter the dimension 500 to both fields by 
double-clicking the weak dimensions. Select OK.

• When creating any sketch, make sure there is no weak dimen-
sion. This ensures that sections or sketches are not overlooked.

• Once finished with the sketch, enter the value of 200 in the 
blind field. The flip option for changing the direction of extru-
sion is beside the blind depth value box.

• The mid plane option also can be selected via the drop-down 
menu beside Blind.

• The top plane will act as a symmetrical mid plane if the mid 
plane option is selected.

• Click OK to finally create the feature.
• Select the Sketch feature from the ribbon at the top. Clicking on 

the feature opens the selection box for all other options.
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• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the Placement tab, and select Define sketch. A pre-
defined sketch also can be selected in this box. However, as no 
predefined sketch is available now, click on Define.

• As Define is clicked, a small toolbox appears for placement of 
the sketch. Select the top surface of the blind feature for the 
sketch. The references for orientation (deciding orientation of 
sketch plane) may need to be selected if perpendicular planes 
of the sketch plane are not available. Once the references are 
available, click on the Sketch button to define the sketch.

• The references to locate the sketch should have been automati-
cally created; however, if the references are not taken, click on 
the Reference icon at the top left corner and select the refer-
ences. Perpendicular planes automatically may be taken as ref-
erences. However, axes, points, or other geometries also can be 
taken as references.

• Select Axis from the sketch ribbon to keep the original sketch 
symmetrical to the axis. Draw one vertical and one horizontal 
axis along the references.

• Create the sketch as displayed in Figure 6.4b.
• When creating any sketch, make sure there is no weak dimen-

sion. This ensures that sections or sketches are not overlooked.
• Click OK.
• Select the Sweep feature from the ribbon at the top. Clicking on 

the feature opens the selection box for all other options.
• Select the previously created sketch as a trajectory in the 

Reference tab.
• Select the Sketch button in the ribbon interface.
• Draw the T profile as per Figure 6.4c.
• Click OK to finally create the feature.
• Save the file.

Hands-On Exercise, Example 6.6: Creating a Helical Sweep and Spring

A helical sweep is sweeping a cross section along a helix or helical curve. 
The helical curve can be created separately or as part of a helical sweep 
as desired by the user. Helical sweeps are very useful to create helical 
profiles like springs, threads, and so forth.

• Select the Sweep feature from the ribbon at the top. Clicking on 
the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the References tab, and select Define helix profile. A 
predefined sketch also can be selected in this box. However, as 
no predefined sketch is available now, click on Define.
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• As Define is clicked, a small toolbox appears for placement of 
the sketch. Select the front plane for the sketch. The references 
for orientation (deciding orientation of sketch plane) may need 
to be selected if perpendicular planes of the sketch plane are 
not available. Once the references are available, click on the 
Sketch button to define the sketch.

• Select Axis from the Sketch toolbar and create a vertical axis 
in the vertical reference line, which will act as the axis of the 
spring.

• Select Line and create a vertical line of length 500 and 100 offset 
from the vertical centerline starting from horizontal centerline 
upward.

• When creating any sketch, make sure there is no weak dimen-
sion. This ensures that sections or sketches are not overlooked.

• Click OK.
• Select the sketch from the helical sweep interface ribbon.
• As the sketch interface is reopened, draw a circle of diameter 

5 mm, placing the center at the bottom of the sketched line.
• Click OK to finish the sketch.
• Set the pitch value to 30 mm.
• Click OK to finally create the feature.
• Save the file.

6.2.5  Loft/Blend

The loft or blend feature is used to create a shape by multiple cross sections 
with or without guide curves. It uses include creating transitions between 
dissimilar profiles.

Hands-On Exercise, Example 6.7: Creation of Rectangle-To- Round 
Transition (Software Used: Creo Parametric)

Steps:
Assume a part file is created with three default planes, RIGHT, TOP, 

and FRONT.

• Select the Sketch feature from the ribbon at the top. Clicking on 
the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the Placement tab, and select Define sketch. A pre-
defined sketch also can be selected in this box. However, as no 
predefined sketch is available now, click on Define.

• As Define is clicked, a small toolbox appears for placement of 
the sketch. Select the top plane for the sketch. The references for 
orientation (deciding orientation of sketch plane) may need to 
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be selected if perpendicular planes of the sketch plane are not 
available. Once the references are available, click on the Sketch 
button to define the sketch.

• The references to locate the sketch should have been auto-
matically created; however, if the references are not taken, 
click on the Reference icon at the top left corner and select the 
references. Perpendicular planes automatically may be taken 
as references. However, axes, points, or other geometries also 
can be taken as references. For our case, select the right and 
front planes for references not being automatically taken.

• Select Axis from the sketch ribbon to keep the original sketch 
symmetrical to the axis. Draw one vertical and one horizontal 
axis along the references of the right and front planes.

• Once the axes are drawn, select Rectangle from the sketch rib-
bon, and click on the top left quadrant to locate the left corner. 
Then click again at the right bottom quadrant to an approxi-
mate distance such that it can form a symmetrical rectangle 
with respect to the axes. Automatically, the symmetrical con-
straint is taken by the system. This practice saves time for creat-
ing constraints.

• Two weak dimensions may be displayed if the weak dimension 
display is activated. Enter the dimension 500 to both fields by 
double-clicking the weak dimensions. Select OK.

• Select Plane from the ribbon interface and create a plane at an 
offset of 400 mm from the top plane.

• Select Sketch from the ribbon and set the newly created plane 
DTM1 as the sketch plane.

• Select References and select the four corners of the rectangle to 
get the vertex points as references.

• Select Axis and create two axes diagonally passing through the 
points.

• Select Circle and create a circle of diameter 300 mm placing the 
center at the cross section of two axes or centerlines.

• Select the Divide option from the sketch editing ribbon, and 
place the break point at all the points where the centerlines 
cross the circle. This divides the circle into four parts.

• Click OK to create the sketch.
• Select the feature Blend from the ribbon.
• Select the Sections tab and select the Selected sketch option.
• Select the rectangle and the circle with a click insert in between.
• Click OK to create the feature.
• Select Shell command from the ribbon and set the thickness to 

8 mm.
• Click on the Reference tab and select the circular and rectangu-

lar surface to remove.
• Click OK to create the feature.
• Select the Blend feature from the model tree and select Edit by 

right-clicking on it.
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• Change the dimension of any of the rectangle’s hands from 500 
to 900.

• Click on Regenerate.

Hands-On Exercise, Example 6.8: Creation of An 
Eccentric Reducer (Software Used: Creo Parametric)

Eccentric reducers are often required to be created in engineering 
applications.

Steps:
Assume a part file is created with three default planes, RIGHT, TOP, 

and FRONT.

• Select the Blend feature from the ribbon at the top. Clicking on 
the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the References tab and select Sketched feature.
• Click on Define, select the sketch plane, and click On sketch.
• The horizontal and vertical references are to be taken automati-

cally by the system.
• Select Circle and place the circle center somewhere above the 

origin point and in the vertical axis.
• Click on the constraint tangent and make the circle tangent to 

the horizontal reference line.
• Make the diameter of the circle 1000 mm.
• Click OK to finish the sketch.
• Click Insert to sketch another section and provide 950 as the 

offset from the secion1 option (offset dimension option).
• Click on Sketch to sketch another circle.
• The horizontal and vertical references are to be taken automati-

cally by the system.
• Select Circle and place the circle center somewhere above the 

origin point and in the vertical axis.
• Click on the constraint tangent and make the circle tangent to 

the horizontal reference line.
• Make the diameter of the circle 750 mm.
• Click OK to finish the sketch.
• Click on the thin feature option and set the value of 10 mm as 

the thickness.
• Click OK to create the feature and save the file.

6.2.6  Draft Creation

A draft is mostly required in preparation of CAD models for casting appli-
cations. The vertical surfaces need to be tapered to facilitate removal of the 
component from the mold. The final component is made first without any 
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draft on the vertical surfaces. The draft is then manually added on every 
surface that needs to be tapered. Draft creation principally requires the fol-
lowing inputs or selections:

• Vertical surfaces that need to be tapered
• A hinge surface from which the angular draft creation will be started
• Angular value for the draft

6.2.7  Cosmetic Features

Cosmetic features are used when a symbolic representation of any feature 
with complex geometry needs to shown. For example, true representation or 
creation of thread geometry may not be required in the case of a large part 
containing several holes. However, it is required to indicate the thread of 
screw holes on the part. A simple dotted line offsetting the hole edges would 
be sufficient to show in the drawing. If the full thread profile is created on 
every hole, unnecessarily, the mode creation time will increase. This would 
also need sufficient memory, which can be a constant.

Cosmetic features are very useful to represent complex and time-consuming  
geometry by symbolic representation. A thread is commonly used to show a 
symbolic representation by cosmetic feature.

Hands-On Exercise, Example 6.9: Cosmetic Feature—Internal 
Thread (Software Used: Creo Parametric; Refer to Figure 6.5)

Steps:

• Create a part file and rename it as Base.
• Select Solid on the right-hand side of the box. This will activate 

the solid mode and environment.
• Uncheck the box of the default template and click OK to create 

a new solid file.
• The template selection box will appear.

FIGURE 6.5
Example of a cosmetic thread in a hole surface.
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• Select mmns_part_Solid. This will allow us to use the solid 
template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The model as displayed in Figure 6.5 will be created.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the top plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Click on drop-down menu beside the rectangle and select 

Center rectangle.
• Place the rectangle center point in the intersection of the hori-

zontal and vertical references.
• Draw a rectangle of dimensions 100 × 50 mm.
• Click OK to create and exit the sketch.
• Select mid plane extrusion.
• Enter the value 20 mm for extrusion depth.
• Click on OK to create the extrusion.
• Click on the feature hole from the Model tab of the ribbon 

interface.
• Change the diameter of the hole to 16 mm.
• Click on the drop-down menu for depth selection and select 

Through all to create the hole throughout the available material.
• Click on the Placement tab.
• Select the top flat face of the extrusion as the placement surface.
• Set the reference type to linear.
• Click on Offset reference area.
• Select the front plane and left perpendicular surface of the hole 

placement surface by pressing the Control key.
• Set the offset value with the front plane to 0 mm or make it 

align.
• Enter the value of 30 mm in the offset field with the selected 

surface.
• Click OK to create the hole.
• Click on the feature hole from the Model tab of the ribbon 

interface.
• Change the hole type to standard hole.
• Select ISO—M16X2 hole size.
• Click on the drop-down menu for depth selection and select 

Through all to create the hole throughout the available material.
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• Click on the Shape tab.
• Set the thread to Through all.
• Click on the Placement tab.
• Select the top flat face of the extrusion as the placement surface.
• Set the reference type to linear.
• Click on Offset reference area.
• Select the front plane and right plane by pressing the Control key.
• Set the offset value with the front plane to 0 mm or make it 

align.
• Set the offset value with the top plane to 0 mm or make it align.
• Click OK to create the hole.
• Click on the feature hole from the Model tab of the ribbon 

interface.
• Change the diameter of the hole to 16 mm.
• Click on the drop-down menu for depth selection and select 

Through all to create the hole throughout the available material.
• Click on the Placement tab.
• Select the top flat face of the extrusion as the placement surface.
• Set the reference type to linear.
• Click on Offset reference area.
• Select the front plane and right perpendicular surface of the 

hole placement surface by pressing the Control key.
• Set the offset value with the front plane to 0 mm or make it 

align.
• Enter the value of 30 mm in the offset field with the selected 

surface.
• Click OK to create the hole.
• Now click on the engineering drop-down menu from the Model 

tab of the ribbon interface.
• Click on Standard thread to ensure the standard available 

thread in the hole surface.
• Click on the Placement tab and select Inner surface of lastly cre-

ated hole.
• Click on the Depth tab and select the top surface as the start 

thread surface.
• Click on the drop-down menu of the Extrusion depth option.
• Click to select an option and select the bottom surface of the 

extrude feature.
• Click OK to create the cosmetic thread.
• Click on Front view from the icon at the top of the graphical area.
• Set the presentation to Hidden line from the top of the graphi-

cal area.
• It can be seen that the simple hole does not include any thread 

surface.
• The second hole has a purple dotted line around the hole indi-

cating the thread representation.
• In the same manner, the third hole, which is a simple hole, is 

displayed with the indicated thread representation due to the 
cosmetic thread feature as displayed in Figure 6.5.

• Save and exit the file.
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Hands-On Exercise, Example 6.10: Creating a Plug 
(Software Used: Creo Parametric; Refer to Figure 6.6)

Steps:

• Create a part file and rename it as Plug. (Other names may be 
given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The plug as shown in Figure 6.6 is to be created.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a hexagon circumscribed on a circle of diameter 42 mm.
• Right-click on the circle and select Construction to make the 

circle a construction entity.
• Click OK to create and exit the sketch.
• Flip the material orientation upward.
• Enter the value 15 mm for extrusion depth.

FIGURE 6.6
Example of a plug with a cosmetic thread.
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• Click on OK to create the extrusion.
• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.7.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click on OK to create the revolve feature.
• Click on Revolve again from the Model tab in the ribbon 

interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the right plane as the sketch plane.
• The top plane shall be automatically taken as reference and ori-

entation as left.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.8.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click to activate the material removal option.
• Click on OK to create the revolve feature.
• Now click on Cosmetic thread from the engineering drop-

down menu from the Model tab of the ribbon interface.
• Click on Standard thread and Unified National Thread (UNF) 

1 1/8.
• Click on the Placement tab and select Major diameter outer sur-

face of revolved feature.

V
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FIGURE 6.7
Constructional sketch of a plug.
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• Click on the Depth tab and select the top surface as the start 
thread surface.

• Select the flat surface of the groove as the end surface.
• Click OK to create the cosmetic thread.
• Save and exit the file.

6.2.8  Pattern

Pattern is an operation to create several instances of any feature with incre-
mental values. The incremental values can be the same or different. If the 
incremental values are different, table patterns need to be used; these may 
be available only in advanced CAD software like Creo.

Hands-On Exercise, Example 6.11: Creating a Fan Screen 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Fan screen. (Other names 
may be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

15.0010.00

H

FIGURE 6.8
Constructional sketch of the head of a plug.
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• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The fan screen as shown in Figure 6.9 is to be created.
• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.10.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.

FIGURE 6.9
(See color insert.) 3-D model of a fan screen.
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FIGURE 6.10
Constructional sketch of a fan screen model.
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• Click on OK to create the revolve feature.
• Select Sketch from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select the front plane as the sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
• The sketcher window will open up and the reference selection 

window appears for selection of references.
• The two references (i.e., top plane as horizontal reference and 

right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create a sketch as displayed in Figure 6.11.
• Click OK to create the sketch.
• Click on Sweep from the Model tab of the ribbon interface.
• Select the lastly created sketch as a trajectory.
• Click on Sweep from the Model tab of the ribbon interface.
• Graphically select the sketch as a trajectory.
• The system assumes the profile sketch point and shows it by 

displaying the directional arrow.
• Graphically click on the arrows of feature creation to draw the 

sweep profile in other control points.
• Click on Sketch to sketch the profile.
• The sketcher mode activates with the sketcher environment.
• Draw a circle at the intersection of references.
• Change the diameter to 2 mm.
• Click OK to create and exit the sketch.
• Click OK to finish the sweep.

• Select the newly sweep feature in the model tree.
• Right-click and select Pattern.
• Select Axis in the Type of pattern selection field.
• Select the central axis.
• Enter the quantity 100 for patterned feature.
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2.00 2.00
10.00

40.00
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FIGURE 6.11
Constructional sketch of a fan screen model.
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• Select the option to make the pattern equally spaced within 360°.
• Click OK to create the patterned feature.
• Click save and exit the file.

Hands-On Exercise, Example 6.12: Creating a Screen 
(Software Used: Creo Parametric; Figure 6.12)

Steps:

• Create a part file and rename it as Screen. (Other names may be 
given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The screen as shown in Figure 6.12 is to be created.
• Click on Revolve from the Model tab in the ribbon interface.
• Set the thicken option.
• Enter the thickness 1 mm.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.

FIGURE 6.12
3-D model of a screen.
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• Draw the sketch as displayed in Figure 6.13.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click on OK to create the revolve feature.

• Select Sketch from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select internal bottom surface as sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
• The sketcher window will open up and the reference selection 

window appears for selection of references.
• The two references (i.e., top plane as horizontal reference and 

right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Project the internal circular edge.
• Click OK to create and exit the sketch.
• Select Hole from the Model tab of the ribbon interface.
• Enter 5 as the diameter of the hole.
• Click the Through all option to make the hole throughout the 

available material.
• Click on the Placement tab and select the central axis and bot-

tom inside surface area by pressing the Control key.
• Click OK to create the hole feature.

• Select the newly created hole feature in the model tree.
• Right-click and select Pattern.
• Select Fill in the Type of pattern selection field.
• Select the inside sketch.
• Select the hexagon pattern.
• Enter 9 mm in the field of spacing of patterned object.
• Click OK to create the pattern.
• Save and exit the file.
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FIGURE 6.13
Constructional sketch of a screen.
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6.3  Surface

Typically, a surface can be defined as the skin of any solid having null thick-
ness. A surface cannot have any mass and mass-related properties. It can 
only have surface area. There is no existence of an independent surface with-
out a solid in the real world. However, very thin sheets often can be modeled 
as surfaces to reduce the complexity of creating thin solids. When a solid 
model is created, surfaces are created automatically associated with a solid. 
The shapes of the surfaces of the solids are controlled by the features used in 
building the solid. It is obvious that if there is such a requirement of making 
any complex surface, there will be a requirement of controlling the surface 
directly. Thus, surface modeling is necessary where the boundary surfaces 
are modeled first and the associated solids are then created by filling the 
boundaries of surfaces.

Typically, the surfaces are represented in parametric or nonparametric 
form. The equation of a surface is given by

 P = [xyz]T.

The parametric representation includes vector function P(u, v) of two 
parameters u and v.

 P(u, v) = [xyz]T = [x(u, v) y(u, v) z(u, v)]T

 umin < u < umax, vmin < v < vmax

 1. Plane surface: Plane surfaces are the simplest in surface geometry cre-
ation. When a line is extruded in a constant vector, a plane surface 
is generated. If a plane surface is parallel to the XY plane, the Z is 
constant. A plane surface is shown in Figure 6.14.

 2. Ruled surface: This kind of surface can be created by selecting a 
boundary profile lying on a single plane. The boundaries of the 
closed sketch can be any curve, and the surface interpolates linearly 
between the curves. Ruled surfaces are linear in one direction and 
connected to boundary curves. Rules surfaces are developable sur-
faces. Cones, cylinders, and symmetrical transitions are examples of 
ruled surfaces. A ruled surface is shown in Figure 6.15.

 3. Surface of revolution: These surfaces are generated by revolution of 
any curve about an axis. A surface generated by revolution of a 
curve is shown in Figure 6.16.
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FIGURE 6.14
Example of a plane surface.
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FIGURE 6.15
Example of ruled surface.
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FIGURE 6.16
Example of a surface created by revolution of a curve.
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 4. Synthetic surfaces: The synthetic surfaces are created by approxima-
tions or interpolations given input data. The synthetic surfaces can 
allow only global control, like a Bezier surface, or can also permit 
local control, like B-spline surfaces. These surfaces are mostly used 
where very accurate controls on surfaces are required, for example, 
blade surfaces in critical fan, where the designs of these surfaces are 
determined by thermal, aerodynamic, and fluid flow simulations.

6.4  Properties and Their Classification

Every feature and model itself possesses some properties. Basically, these 
properties are the information associated with a respective feature, object, or 
entity. Some of the information drives the object, whereas the rest are driven 
out from the object. Parametric software provides facilities and options to 
change its various properties, which can actually control the object associ-
ated with it. For example, a dimension can be a property of a hole feature, 
and by changing the dimension, the size of the hole can be varied, and thus, 
mass properties of the model also vary. Therefore, dimension is the property 
that derives the feature, whereas mass property is driven out from the model.

Thus, properties can be broadly classified as two categories driving prop-
erties and derived properties.

 1. Driving properties: Driving properties can be defined as the prop-
erties of an object that preserve the various other properties of the 
object and by changing which the model is affected. Most geomet-
ric dimensions are main driving parameters. Varying a dimension 
definitely results in varying the shape of the associated feature. 
Therefore, it is always required predict the desired effect in varying 
the driving properties.

 2. Derived properties: Derived properties are those that are pre-
served by the object and a direct change of which is not possible. 
Geometrical properties like perimeter, area, and so forth are derived 
properties. Direct change of this perimeter is normally not possible 
in CAD.

 Example: Draw a circle of diameter 100 mm as shown in Figure 6.17. 
If the diameter gets changed to any value, the perimeter will auto-
matically get changed. The diameter of the circle is a driving prop-
erty here, whereas the perimeter is the derived geometrical property.

 3. Mass properties: By definition, mass is the amount of matter of any 
object, and the properties of the matter are called mass properties. 
The mass properties are calculated from the shape of the model 
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and its associated material properties. The commonly derived mass 
properties are as follows:

 a. Volume: Volume is a property that is calculated automatically 
by the CAD system when a solid is created. The dimension of 
volume is (length)3. Hence, the unit of volume depends on the 
set unit of the length. The length unit can be set in millimeters, 
meters, inches, and so forth. Length unit conversion factors are 
shown in Table 6.1.

 Volume is a derived parameter. It cannot be controlled directly in 
CAD.

 b. Mass: Mass is the amount of matter contained in a body or object. 
Mass is an important parameter in CAD that is often required to 
be measured when designing any component. Mathematically, 
mass = volume × density. Density in CAD is to be taken from the 
material properties in CAD. When working with big assemblies, 

FIGURE 6.17
Example of derived properties.

TABLE 6.1

Length Unit Conversion Factor

1 km 1 m 1 cm 1 mm 1 μm 1 in. 1 ft. 1 yd.

1 km 1 1 × 103 1 × 105 1 × 106 1 × 109 39,370.08 3280.84 1093.61
1 m 0.001 1 100 1 × 103 1 × 106 39.37 3.28 1.094
1 cm 1 × 10−5 0.01 1 10 1 × 104 0.3937 0.0328 0.010936
1 mm 1 × 10−6 1 × 10−3 0.1 1 1 × 103 0.03937 0.00328 0.0010936
1 μm 1 × 10−9 1 × 10−6 1 × 10−4 1 × 10−3 1
1 in. 1 0.08333 0.02777
1 ft. 12 1 0.333
1 yd. 36 3 1
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it may not always be possible to apply the same material in every 
part. However, if the total assembly is made by materials  of the 
same density, we can easily get the mass by getting the volume 
from CAD and multiplying it with density manually. Mass is a 
derived parameter, which cannot be controlled directly in CAD. 
Dimension or density alteration is required to change the mass.

  The most used units of mass in most of the CAD software are 
as follows:

 i. Kilogram (kg): It is the System International (SI) or meter- 
kilogram-second (MKS) unit of mass.

 ii. Gram (g): It is the centimeter-gram-second (CGS) unit of mass.
 iii. Pound (lb.): It is the foot-pound-second (FPS) unit of mass.
 iv. Slug: It is the unit of mass expressed commonly in imperial 

system.
 v. Tonne: It is the unit in the metric system for a bigger quantity 

of mass.
 c. Weight: It is the amount of force that is experienced by the body 

due to the gravitational force of the Earth. Mathematically, 
weight = mass × gravitational force. The weight is mostly 
required in cases of static or dynamic analysis. If the density and 
gravitational force are set properly in CAD, accurate weight can 
be obtained very easily. Weight is also a derived parameter; it 
depends on mass and gravitational force.

 d. Density: Density is a secondary unit, which can be derived from 
the set unit of mass and length, that is, if the set unit of mass in 
CAD  is kilograms and length is meters, then the unit of density 
would be kg/m3. The density in a material is a driving parameter, 
which in turn decides the mass of the material of particular volume.

 e. Surface area: Surface area is the area of the part exposed to the air. 
Surface area is also dependent on the unit of length.

 f. Cross-sectional area: Cross-sectional area is the area of a part that 
is cut by a particular plane.

 g. Center of gravity: Center of gravity can be imagined as the point 
through which the weight of the whole body acts. For a part of 
one material, the center of gravity depends on the shape and size 
of the component and its features. The center of gravity is mea-
sured in a linear dimensional unit from a reference point in three 
axes (x, y, and z). The center of gravity is often required to be 
determined, since it is the key deciding factor to locate the lifting 
points if required for the part.

 h. Moment of inertia: The unit of moment of inertia is dependent on 
the unit of length.
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 i. Section modulus.
 j. Radius of gyration: Mathematically the radius of gyration is 

K
I

M
=

 where

 I = moment of inertia
 M = mass of the body

 4. Aesthetic properties: Aesthetic or graphical properties are the proper-
ties that control the display of the CAD model. Aesthetic properties 
are required due to the following reasons:

 a. To make a proper presentation of the model
 b. To differentiate the parts and surfaces
 c. To make the decal of the various surfaces
 5. Material properties: Most mass properties like density, mass, weight, 

and so forth are dependent on material properties.
 6. User-driven properties: Most advanced parametric CAD software 

enables facilities to link the user-driven properties with driving 
properties. In other words, the user-driven properties control 
the driving properties; thus, the model varies with user-driven 
properties.

6.5  Family Tables

Geometrically similarly shaped products with varying dimension values or 
properties are created in a family table. A family table defines the creation of 
a range of products from the same family with varying dimension values or 
properties entered in tabular form. The product properties that can be varied 
are as follows:

 1. Dimensions: Family tables are mostly used for the range of compo-
nents with dimension variations.

Hands-On Exercise, Example 6.13: Creation of a Blind Flange 
(Software Used: Creo Parametric)

Steps:
Assume a part file is created with three default planes, RIGHT, TOP, 

and FRONT.
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• Select the Revolve feature from the ribbon at the top. Clicking 
on the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the References tab and select Sketched feature.
• Click on Define, select the sketch plane, and click on Sketch.
• The horizontal and vertical references are to be taken automati-

cally by the system.
• Create a vertical axis at the center point.
• Select Line and draw the geometry as shown in Figure 6.18.
• Click OK to finish the sketch.
• Make sure that the entered angle for feature creation is 360°.
• Click on Hole to create a hole on the flange.
• Select the full face surface of the flange (the surface without the 

raised face) as the primary placement reference.
• Click on Type and select Diameter for diametric referenced 

hole.
• Click on Offset reference and select the axis and a plane.
• Enter the pitch circle diameter (PCD) as 190.5 mm.
• Make the hole trough and the diameter to be 16 mm.
• Click on Finish to create the feature.
• Select the hole in the model tree and click on Pattern in the rib-

bon to create the pattern.
• Select 360 as the total angle and enter the number 8 for creation 

of 8 holes.
• Go to the Tools tab and click on Family table to make the other 

components of this family by varying the dimensions.
• Click on the vertical arrow to select the dimensions.
• Select the dimensions (230, 190.5, 16; number of holes; thickness 

of −22.3; and raised face diameter of 171 mm).
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FIGURE 6.18
Constructional sketch of a blind flange.
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• Click on OK and click on the horizontal arrow thrice to create 
three components.

• Enter all the dimensions as shown in Figure 6.19.
• Click on Verify. The status shall be successful for verification.
• Click on OK to finish the feature.
• Save the file.

 2. Parameters: Many times, dimensions are in relation and controlled 
by meaningful parameters; in such cases, parameters are varied in 
a family table. Apart from that, there are many parameters that may 
not affect the model geometry; these parameters also can be con-
trolled by a family table. Density can be such a type of parameter 
that changes due to change of materials.

 3. Features: A family of a product can also contain some product that 
has some particular features that are not present; in such cases, it is 
necessary to control the feature presence by a family table.

Hands-On Exercise, Example 6.14: Creation of a Slip On Raised 
Face (SORF) Flange (Software Used: Creo Parametric)

• Follow the steps in the example on the use of the Up to the 
selection option to create the blind flange.

• Click on Revolve in the feature ribbon.
• Make the revolved feature of hub extrusion.
• Select the Revolve feature again and create the inside hole or 

cut for the pipe.
• Select Family table from the Tools tab.
• Select the vertical arrow to select variations again.
• Click on a feature to select.
• Select the last two revolve features that were created for SORF 

flange.
• Click OK.
• Enter N for all blind flanges and Y for all SORF flanges in the 

feature field.
• Click on Verify to see the status; it should be successful for all 

the instances.
• Save the file.

FIGURE 6.19
Dimensional variation of a family table for a blind flange.
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Primarily, the application of family tables facilitates the use of the same 
component and reduces the effort of making similar products. Secondarily, 
the application of family tables enhances automation.

Examples:

 1. Bolt
 2. Nut
 3. Flanges
 4. Material alteration
 5. Painting calculation

6.6  Use of Macro/Map Key

A macro or map key in Pro-Engineer or Creo is a recording of sequential com-
mands that can be executed to perform similar tasks to save time. Typically, 
it records the sequential actions of execution of commands. Macros or map 
keys can also be edited. Macros are saved in a file that is played back by 
using keyboard commands or a graphical icon. CAD software permits the 
assignment specific keyboard shortcuts or choosing of a graphical icon of the 
user’s choice. Though a macro or map key can be used to record and play-
back any sequential commands, the usefulness is limited to certain applica-
tions where designers need to perform repetitive work. These are as follows:

 1. Creation of geometry
 2. Geometrical measurements
 3. Changing of parameters

The macro creation method is very simple compared to any other automa-
tion process. The use of macros or map keys is as follows (software used: 
Creo parametric):

 1. Create the macro: Type Map key in the command search box and 
click on it. A map key creation box will open. Click on New to cre-
ate a new map key. Enter the key in the key sequence field. This key 
will activate the map key after recording. Enter the name and full 
description of the map key.

 2. Start recording: Start recording and carry out all the work that can be 
included in the map key.
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 3. Perform the activities sequentially: Whenever recording for a map key, 
it is essential to perform sequentially all the operations that will be 
included in the map key.

 4. Stop recording: Stop recording if the map key creation is finished. If 
there is some operation that need not be included in the map key, 
like editing of geometric dimensions, the recording can be paused 
and restarted again.

 5. Run the macro: Once the map key is created, before using it for repet-
itive purposes, run it to ensure that the performance is up to the 
requirement.

 6. Edit the macro.
 7. Save it to file.
 8. Assign a key sequence or graphical icon.

Hands-On Exercise, Example 6.15: Map Key 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Map key Example. (Other 
names may be given, but it is advisable to provide a relevant 
name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• Click on the command search field on the upper right hand corner.
• Write Map key to search for the Map key command. This com-

mand is not command list.
• Click on the Map key command in the searched result window.
• A map key window appears.
• Click on New in the map key window.
• A Record map key window appears.
• Write “b” in the key sequence field. The map key will be exe-

cuted by pressing the key “b.”
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• Write the name of the map key as Block. Any name can be 
given, but it is always advisable to give a meaningful name so 
that one can easily remember and it can be understood by any-
one other than the creator.

• Write down the purpose of this map key in the description 
field. In this case, write To make a block in the description field.

• Click on Record to start the recording of command sequences.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the top plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Click on the drop-down menu beside the rectangle and select 

Center rectangle.
• Place the rectangle center point in the intersection of the hori-

zontal and vertical references.
• Draw a rectangle of dimensions 500 × 500 mm.
• Click OK to create and exit the sketch.
• Select mid plane extrusion.
• Enter the value 200 mm for extrusion depth.
• Click on OK to create the extrusion.
• Click on the Stop map key button in the record map key window.
• Click OK to create the map key.
• Click Run to run the map key.
• On clicking Run map key, the user is immediately asked to 

select the sketch plane.
• Select the top face of the model as the sketch plane.
• Draw a center rectangle, again placing the center point in the 

intersection of the horizontal and vertical references.
• The system will create the extrusion of height 200 mm.
• Right-click on the lastly created extrusion in the model tree.
• Select Edit.
• The dimensions will be displayed.
• Change the dimensions as required.
• Regenerate the model.
• Save and exit the file.

6.7  Parametric Modeling

Parametric modeling is modeling controlled by associated parameters. In 
other words, the parameters control the geometry of the modeling. If the 
parameter changes its value, the geometry associated with the parameter will 
also change; thus, the component shape changes. A model can be nonpara-
metric or parametric. If the requirement is such that the modeled component 
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is very simple with a very small number of features, parametric modeling 
techniques may not be economical with respect to time. However, for a 
robust model or in developing product, parametric modeling is extremely 
useful to save time and achieve accuracy. Parametric modeling has the fol-
lowing advantages:

 1. The model is related to meaningful parameters.
 2. Changing of any parameter automatically changes the model.
 3. The effect of geometries with respect to certain parameters can be 

seen and plotted, which enables a designer to understand that the 
behavior of changing parameters can be accomplished.

 4. Relating of parameters is easy to understand with meaningful 
parameter names.

 5. The same parameter can be used in various relations.

Apart from its numerous advantages, parametric modeling also has some 
difficulties because of which users sometimes ignore creation of parametric 
models. These difficulties are as follows:

 1. It requires good knowledge and understanding of the parametric 
modeling techniques and CAD software.

 2. It involves more time to create the parametric model.
 3. It involves programming knowledge or knowledge of syntax to cre-

ate relations among parameters since most of the parametric model-
ing involves the use of relation among the parameters.

 4. Some parameters may lead to impractical values of model dimen-
sions, which in turn lead to feature failure. Most basic CAD users 
find it difficult to resolve the failed features. Also, feature failure 
options are specific to different CAD software, so these require good 
knowledge of the CAD software.

 5. It is difficult to edit a robust parametric model if the design changes 
and, particularly, for other users who were not involved in the cre-
ation of the parametric model.

 6. Many geometric dimensions are not meaningful or can be related to 
parameters, which can also lead to feature failure.

 7. A set of relations is required to be available before creation of 
modeling.

Parametric modeling software like Creo is continuously developing and 
increasing the ease of users’ accessibility to reduce the aforementioned difficul-
ties. Instead of these difficulties, parametric modeling significantly  contributes 
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to reducing design time and increasing accuracy. It is suggested that users 
use parametric modeling as much as possible.

In order to create a parametric model, some steps are as follows:

Defining the parameter Relation Geometry creation with
   required constraints

6.8  Parametric Modeling Procedures

The modeling operation defines the creation of 3-D models in the CAD 
software. It is the most time-consuming work performed in CAD software. 
Accurate modeling is the most significant work for CAD users since any out-
put from CAD is related to the prepared model. The modeling operation 
includes the following.

6.8.1  Parameter Creation

Parameters are required, particularly for parametric modeling. It is advis-
able that users create all the driving or major parameters before creating any 
object. Highly parametric software like Creo allows defining the attributes 
of parameters. These include type, dimension, units, accessibility, and so 
forth. The types of parameters are as follows:

• Integer: If a parameter is defined as an integer, the parameter will 
always store the integer portion of any real number if the value is 
derived from any relation.

  Example: Parameter N is defined as the quantity of holes arrayed 
in s strips of x length with spacing of dx. Now the N can be obtained 
from the formula N = x/dx. Now, it is obvious that the quantity of 
the holes shall be in integers; therefore, the N parameter has to be 
defined as an integer so that the system will automatically take the 
integer part of the derived value.

  If 

 x = 500, 

 dx = 60, 

 N = x/dx = 500/60 = 8.33333, 

 the integer part of the derived value is 8, so the quantity will be 8.
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• Real number: A parameter having the attribute of real number shall 
display the actual calculated value. In case of mass properties, real 
number attributed parameters are always useful.

• String: String is the parameter that is used for alphabetical informa-
tion, such as product name, project name, description, and so forth.

• Logical: A logical parameter stores only either a yes or no value 
within it. In many cases, to build a large model with relation, logical 
parameters are essential.

6.8.2  Feature Creation

The first step of creating any object is feature creation. As described ear-
lier, the features can be many, like solid modeling features, surface features, 
or datum features. In parametric CAD software, every specific feature can 
store parameters. If the parameters are created before as described earlier, 
the parameters can be directly entered in the creation of features when 
prompted for values. In this way, the built relation is kept inside the feature, 
which may be useful when building large parametric models but difficult to 
find out. In such cases, keeping all the relations in a part is very useful and 
easier to understand.

Hands-On Exercise, Example 6.16: Creating a Plug Sheet 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Plug sheet. (Other names may 
be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually displayed in the summary section 

of any CAD software. The setting of units usually is in the 
tools or settings.

• The plug sheet as shown in Figure 6.20 is to be created.
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• Click Parameters from the Tools tab.
• Create the following parameters.

Name Type Value

HOR_PITCH Real number 60.00
VER_PITCH Real number 60.00
NO_OF_PLUG_PER_ROW Integer 10
NO_OF_ROWS Integer 4
CLEARANCE Real number 100.00
SHEET_THICKNESS Real number 20.00
SHEET_LENGTH Real number 0.00
SHEET_WIDTH Real number 0.00

• Click OK to create the parameters.
• Click on Relations from the Tools tab of the ribbon interface.
• The relations creation window opens up.
• Write down the following relations.

• sheet_length = HOR_PITCH*(NO_OF_PLUG_PER_ROW – 
.5)  + CLEARANCE*2

• sheet_width = Ver_pitch*(NO_OF_ROWS − 1) + 
CLEARANCE*2

• Click on Verify on the upper right side in the relation window 
to verify the relations.

• The message “Relations have been successfully verified” should 
come out.

• Click OK to close the relation window.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.

FIGURE 6.20
3-D view of a plug sheet.
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• Draw a rectangle placing the left corner in the intersection of 
the horizontal and vertical centerlines.

• Double-click the length dimension of the rectangle and enter 
sheet_length.

• Double-click on the width dimension of the rectangle and enter 
sheet_width.

• Click OK to create and exit the sketch.
• Select mid plane extrusion.
• Enter the value sheet_thickness in the field of extrusion depth.
• Click on OK to create the extrusion.
• Select Hole from the Model tab of the ribbon interface.
• Select a standard screw hole and include a thread surface.
• Select UNF of size 1 1/8-12.
• Select the Through all option.
• Click on the Placement tab and select the front large face of the 

sheet.
• Select the left and bottom surfaces as offset references.
• Double-click on the offset dimensions and enter clearance.
• Click OK to create the hole feature.
• Similarly, create another hole of the same size by following the 

aforementioned procedure on the same face with offset refer-
ence from the existing hole.

• Double-click on the offset dimensions and enter ver_pitch for 
the vertical offset dimension field and hor_pitch/2 for the hori-
zontal pitch dimension field.

• Click OK to create the hole feature.
• Select both the holes in the model tree by keeping the Control 

key pressed.
• Right-click and select Group.
• Select the newly created group in the model tree.
• Right-click and select Pattern.
• Select Directions in the Type of pattern selection field.
• Select the front plane in the direction 1 field and top plane in 

the direction 2 field.
• For the incremental dimension field, enter hor_pitch for direc-

tion 1 and ver_pitch*2 for direction 2.
• Enter the quantity 2 for patterned feature in both directions.
• Make sure the patterned features are approaching the empty 

area of the sheet.
• Click OK to create the patterned feature.
• Click on Relations from the Tools tab of the ribbon interface.
• The relations creation window opens up.
• Write down the following relations.

• p23 (graphically may need to select by clicking the pattern 
feature, feature number may be different) = NO_OF_PLUG_ 
PER_ROW

• p24 (graphically may need to select by clicking the pat-
tern feature, feature number may be different) = NO_OF_ 
ROWS/2

Copyrighted Material - Taylor and Francis



149Part Modeling

• Click on Verify on the upper right side in the relation window 
to verify the relations.

• The message “Relations have been successfully verified” should 
come out.

• Click OK to close the relation window.
• Click on Parameters from the Tools tab of the ribbon interface.
• Change any parameters like hor_pitch or NO_OF_PLUG_ 

PER_ROW.
• Click OK to close the parameter window.
• Click on Regenerate and notice the differences.
• Save and exit the file.

6.8.3  Relation Buildup

Relation building is the most significant step in parametric modeling and 
requires a good knowledge of the product and the CAD software too. As 
discussed earlier, relationships can be maintained within the feature or at 
the part level. Both have specific advantages and difficulties.

Advantages of keeping relations within features:

• A structure for relations can be maintained.
• It is useful to keep the relations separate for specific features.
• It consumes less time if the parameters are available during creation 

of features.
• It is useful for creating parametric models of large assemblies or 

components.

Disadvantages:

• It requires good knowledge to create and understand the parametric 
model.

• It is difficult to find out the problem in some relations in the case of 
feature failure issues.

• Parameters are required to be created before features, which may 
not be possible all the time.

• It is not very useful for the simple parametric model.

If the relations are kept in the part mode or in the top level in a part, rela-
tions are required to be created after creation of the feature. This involves 
selection of dimension symbols and relating them to parameters. This 
method has advantages and disadvantages.

Advantages:

• It requires less skill and knowledge to create the parametric model.
• The relations can be easily found in the part mode.
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• Since parameters need not be created before features, one can inden-
tify the required parameter after creating the feature and recreate it 
before creating relations.

Disadvantages:

• Sometimes, features are required to be identified by feature number 
or internal IDs, which involves the use of specific syntax.

Hands-On Exercise, Example 6.17: Relation in Parametric 
Modeling (Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Vertical Shell. (Other names 
may be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Click on the Tools tab in the ribbon interface.
• Click on Parameters.
• The parameters window will appear.
• Add a parameter and rename it as Dia.
• Keep the type as real number.
• Enter the parameter value as 500.
• Add a parameter and rename it as Length.
• Keep the type as real number.
• Enter the length parameter value as 1000.
• Add another parameter and rename it as Volume.
• Keep the type as real number.
• Keep the volume parameter value unchanged at 0.000.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the top plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a circle keeping the center at the intersection of the hori-

zontal and vertical reference lines.
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• Double-click on the diameter dimension and enter Diameter.
• Click OK to create and exit the sketch.
• Select Blind extrusion.
• Enter Length in the field for extrusion depth.
• Click on Relation from the Tools tab of the ribbon interface.
• The relation window opens up.
• Write down the relation “volume = ((PI()/4)*diameter^2)*length.”
• Click on Verify on the upper right side of the relation window.
• A notification box with a message “Relations have been suc-

cessfully verified” should appear.
• Click OK to close the box.
• Click on the Analysis tab of the ribbon interface.
• Click on Mass properties.
• The mass properties analysis window will appear.
• Click on Preview in the mass properties analysis window 

or middle-click on the mouse button to calculate the mass 
properties.

• Mass properties will show in the mass properties box. The 
appeared volume will be the same as calculated volume.

• Now click on Relation from the Tools tab of the ribbon interface.
• The relation window opens up.
• Change the relation to “length = volume/((PI()/4)*diameter^2).”
• Click on Verify on the upper right side of the relation window.
• Notice that the length parameter box is locked now.
• Change the volume to some new value.
• Click on Verify on the upper right side of the relation window.
• Click OK in the bottom of the relation window to close.
• Click on Regenerate in the upper left section.
• The length will be automatically changed.
• Save and exit the file.

Other way: The CAD software itself creates unique symbols for each 
dimension that is entered into the system. The symbols follow a format as 
specified in the CAD software, like d0, d1, and so forth, which increases 
as the user continues building more features and entering values. When 
creating relations, the parameters have to be linked or relate to each of 
these dimension symbols; thus, CAD understands the relations between 
the parameters.

 Inherent dimension symbols = f(parameters).

This method is very easy to create; however, sometimes, it is difficult to 
understand and find symbols for which the relations are made.

The smartest way is to rename the inherent symbols to some meaningful 
name that allows the user to understand the relationship easily and thus 
reduces complexity.
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6.8.4  Property Assignment

Once the feature creation and relation buildup is completed, the required 
properties need to be assigned. Sometimes, the properties are also required 
to be assigned during or before building up the relation. The properties that 
are required to be assigned are as follows:

• Material properties: Material properties automatically get assigned 
with the assignment of material into the part. The important mate-
rial properties include the following:
• Density: The ratio of mass to volume
• Young’s modulus: Also called modulus of elasticity
• Bulk modulus

• Coefficient of thermal expansion

• Poisson’s ration: The ratio of volumetric strain to linear strain
• Aesthetical properties

• Mass properties: Mass properties can be derived from the model or 
can be overwritten as per a user’s requirement. The mass properties 
are as follows:
• Mass: The matter of quantity in any part
• Volume: The space required for the part
• Center of gravity: The point through which the whole mass of the 

product is acted
• Moment of inertia: The second moment
• Section modulus: The ratio of the moment of inertia to the distance 

of the fiber from the center of gravity
• Radius of gyration

In many cases, mass properties are required to be used in the relationship 
to create further parameters. In such cases, mass properties are required to 
be generated or assigned before building up relationships.

In many cases, the complete drawing for a 3-D model may be unavailable 
or strategically not given. For example, a company may not give all the draw-
ings to make their product, which are proprietary items. However, they can 
provide enough data that is actually required for engineering applications 
like total mass, center of gravity, and so forth. In such cases, overwriting of 
mass properties is essential, which in turn overwrites the mass properties 
for calculation as per a user-entered value.

• Aesthetical properties: Aesthetical properties are the graphical proper-
ties assigned to parts or surfaces. Graphical properties are discussed 
in detail in the latter part of this book; however, the following are 
essential in the subject’s point of view:
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• Color: Assignment of color is the simplest way to distinguish dif-
ferent parts and surfaces. In part mode, it is obvious that the use 
of color is limited to use in surfaces. Some CAD software also 
allows coloring of individual features. Also, some CAD software 
automatically provides color on building up different features. 
This enhances visibility. Color is used to understand different 
surfaces or make the model more realistic so that users get an 
idea of how the component will be seen when made in real life.

• Transparency: Transparency allows the part beneath to be seen. 
It helps to model the transparent parts or to see the internal fea-
tures under the exterior surfaces.

• Texture: Textures are assigned as a picture on a specific surface or 
part. Textures are used in the following cases:

 – When there are painted surfaces with a specified picture, 
a user can realize the appearance after making the actual 
component.

 – When the model would be too complicated or can con-
sume too much memory during modeling of full features, 
like small repetitive features (e.g., gratings, screens). The 
easiest solution for this situation is to model the part 
with the simplest detail and use the texture of the actual 
component or surface, for example, gratings and so forth.

 – Textures are also used for sample models with the com-
pany name and details, which might be used for adver-
tising or promotion purposes before manufacturing the 
actual part.

• User-defined properties or parameters: When modeling a component a 
user may have some specific requirements to measure, which must be 
calculated or stored in the part; those parameters can be retrieved in 
a latter stage. For example, sometimes, the actual material cost needs 
to be calculated. The unit material cost can be placed as a parameter.
• Let the unit cost of the material be $X/kg. The total calculated 

mass of the part from the model is M kg. Hence, the total cost of 
the part shall be $MX. If this relationship can be placed on screen 
text, the designer can see what the raw material cost involves 
when building each feature.

• Let the unit cost of painting be $x. Hence, as the feature increases, 
it may include or reduce some more of the surface that may need 
to be painted. If such a relation can be written, the total painting 
cost = area × $x = $AX = total painting cost. Users may build 
relationships to calculate the total cost including raw materials + 
manufacturing + material handling + painting and so forth to 
get the total cost.
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6.8.5  Checking/Verifying

Verifying or checking the part is most important from the design point of 
view before declaring that a part is completed. Verifying can be of two types:

• Verifying from the CAD point of view: When the part is parametrically 
modeled, it is obvious that the assigned parameters may change 
during finalization of design. Thus, all the features are required to 
be regenerated as the parameters get changed. It is often seen that 
features may fail if there is any unsatisfied relation. A part or model 
with failed features often leads to improper model shape or is the 
cause of other feature failures or improperly derived parameter gen-
eration. Thus, it has to be ensured that the model is free of any fail-
ure feature and improper relation.

• Verifying from the design point of view: Sometimes, the design may 
need to be more optimized or can be modified. It is always advisable 
to stretch on preparing each model to its final design, since further 
changing the model may affect its dependents, like other related 
parts in an assembly.

6.8.6  Editing

It may be a requirement to edit the part or relations before declaring them 
final and releasing them to proceed with further applications. In parametric 
modeling, when all the features are linked with parameters, relations are to 
be carefully edited.

6.9  Modeling Techniques

 1. Planning of features: Creating a simple 3-D model becomes very easy 
as CAD software increases its user-friendliness. However, creating 
a complex model always requires some planning before starting the 
model; otherwise, there will be ample loss of time. Especially in the 
case of parametric modeling, the planning is important when fea-
ture-based relations are to be written. If the model is being prepared 
from an existing drawing, it is advisable that the feature creation 
process be followed as per the manufacturing procedure. This helps 
in visualizing the manufacturing steps involved in the production of 
the product and always ensures the right way of creation.

 2. Creation of required datum: Datum items are always required to start 
with the model. Also datum planes are extremely useful for using 
reference entities. The uses of datum items are as follows:
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 a. Datum plane as level or surface
 b. Coordinate system as reference entities

 The advantages of using reference entities are as follows:
 − They do not depend on solid feature regeneration. Sometimes, 

some surfaces may be excluded due to feature regeneration.
 − They can be renamed as required.
 − They can be created and used in the template part. Since they 

do not have any mass properties, they do not have any effect 
on the mass properties of the final model.

 − Their shapes can be adjusted as required.
 − They can be patterned or copied.
 − They can be put into layers independently so that during pre-

sentation, no datum items will be displayed, if required.
 3. Creation of features: Creation of features is the next step after creation 

of required datum items. Sometimes, the datum items may need to 
be created during or after feature creation. It is advisable to rename 
each feature to some meaningful name when creating a parametric 
and complex model. The following points are important when creat-
ing features in a parametric model.

 a. References shall be taken carefully and be kept in mind such that 
in any case, the references should not get outdated or deleted 
during regeneration with changed parameters.

 b. If the relations are entered in features, the proper renaming shall 
be done for the features with the relation.

 c. Features shall be created in accordance with practical design 
practice.

 d. If there are some properties to be assigned to the feature, it is 
advisable to assign the properties just after creation of the fea-
ture, if possible.

 4. Checking of final models: Final model check.

6.10  Application-Based Modeling

It is often seen that the procedure obtained to prepare any CAD model also 
differs based on application. The applications for which commonly CAD 
models are used are as follows:

• Casting or molding: The modeling required for casting may be derived 
from the casting applications itself.
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• Assembly or fabrication: 3-D models or drawings for assembly or fabri-
cation often do not need fully detailed features. It is often not useful 
to create a detail model for assembly or fabrication.

• Mechanism or simulation: If the purpose of the modeling in CAD is 
to see or analyze the mechanism or for simulation, sometimes it is 
beneficial to exclude the irrelevant features from the model, which 
simplifies the model and also saves time and memory.

• Analysis: The type of analysis required for the model or design is 
also derived from the extent of detailing. If every feature has to be 
thoroughly checked from the design point of view, it may be called 
a detailed model.

• Illustration: A CAD model is always called for in the creation of a 
manual. Obviously, the models need not be too detailed for illustra-
tion, and sometimes, a similar-looking model serves the purpose.

• Design automation: When a design automation is planned for and 
the frequency of use is much more, then it is advisable to create as 
detailed a model as possible.

• Concept generation: CAD models are very useful in generation of 
concepts. The outlook of a component after certain operations may 
require a CAD model. It is obvious that the time available for this type 
of modeling is not much, and also, a detailed model is not needed.

• Applicable codes and standards: In engineering, there is a standard 
practice in many cases where complicated models are presented 
with simpler symbols. It is essential to maintain the symbols while 
excluding detailed modeling of the part.

 1. Identification of requirements: When creating any CAD model, it is 
essential to evaluate the requirement so that the time and effort 
to prepare the CAD model can be optimized while satisfying the 
requirement. All the ideas of creating a parametric model are to save 
time, reduce accurate model with optimized design. Identification 
of requirements can be determined by the following procedure:

 a. Count the dependencies on the features: If the features are too inter-
dependent with specified relations, it is recommended to use a 
parametric model so that if the design varies at any stage of fea-
ture creation, the relative dependent feature also gets changed.
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 b. Estimate the time requirement to make the model: Whether it 
requires too many man hours to prepare the model and 
chances of changes in the future will not much affect the 
model.

 c. Count the number of uses to be required for the model. If the 
model is required to be used many times, it is better to make 
a highly parametric model. Normally, the requirement of a 
parametric model may have been called for even only for a 
model that can be used only for a second time. Therefore, the 
requirement is for a highly parametric model.

 d. The extent of variability of the design is an important crite-
rion and deciding factor for creation of a parametric model. 
If the product is in the conceptual research and development 
stage, where the entire set of relations for any feature may 
get changed, a parametric model may not be economical. 
However, if the relations for some features have been frozen, 
a parametric model can be fruitful.

 e. To whom the model is to be shown or presented is also an 
important criterion in modeling. If it is to be presented to a 
customer, obviously, the model has to be as detailed as pos-
sible, unless the customer agrees otherwise.

  Once the requirement of a parametric model is stabilized, the 
next step is to determine the extent of parameterization. It is 
always desirable to make a complete parametric model, where 
the user only has to give input and the entire model generates 
the final finished product. However, the extent of work may not 
be economical for a complete parametric model. Therefore, this 
kind of situation can be approached with a semi-parametric 
model, where the parameterization shall be up to a user’s needs.

 2. Creation of relation: It is essential to understand the design rela-
tion of each feature before transferring it to a CAD program. 
Many times, it is seen that some feature does not have much 
importance in relation from a design point of view; however, it 
is required in CAD for a complete parametric model. This fea-
ture becomes important since many important features may not 
get regenerated due to failure of unimportant features during 
regeneration. All the relations shall be thoroughly checked for 
accuracy and integrity.

 3. Required parameter creation: When all the sets of relations created 
are in a notepad or any text editor, the next job is to implement 
in CAD. It is recommended to create all the parameters and rela-
tions before creating the model. Creation of any relationship 
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during the feature creation may be overlooked, and the model 
may run into the problem.

 4. Creation of model: Once the parameters and relationships are com-
pleted, the model shall be created as per planning of features.

Hands-On Exercise, Example 6.18: Creating an 
Eyebolt (Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Eyebolt. (Other names may be 
given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The eyebolt as shown in Figure 6.21 is to be created.
• Click on Sweep from the Model tab of the ribbon interface.
• The sweep trajectory will be created first followed by a sweep 

operation.

FIGURE 6.21
3-D view of an eyebolt.
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• The trajectory can also be created inside the sweep operation; 
however, the sketch will not be available if the sweep feature 
is deleted.

• Select Sketch from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select the front plane as the sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
• The sketcher window will open up and the reference selection 

window appears for selection of references.
• The two references (i.e., top plane as horizontal reference and 

right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create a sketch as displayed in Figure 6.22.
• Click OK to create and exit the sketch.
• Click on Sweep from the Model tab of the ribbon interface.
• Graphically select the sketch as a trajectory.
• The system assumes the profile sketch point and shows it by 

displaying the directional arrow.
• Graphically click on the arrows of feature creation to draw the 

sweep profile in other control points.
• Click on Sketch to sketch the profile.
• The sketcher mode activates with the sketcher environment.
• Draw a circle at the intersection of references.
• Change the diameter to 20 mm.
• Click OK to create and exit the sketch.
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FIGURE 6.22
Constructional sketch of an eyebolt.
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• Click OK to finish the sweep.
• Click on Round feature from the Model tab of the ribbon 

interface.
• Set the value of fillet to 5 mm.
• Select the edges of the circular face of the eye.
• Click OK to create the feature.
• Click on the Helical sweep option from the drop-down menu of 

Sweep from the Model tab of the ribbon interface.
• Click on the References tab and select Define to define the helix 

sweep profile.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a geometry centerline on the vertical reference line in the 

middle.
• Add the reference of the left outer edge of the straight cylinder 

part of the hook.
• Draw a vertical line at the reference edge. The bottom point of 

the line shall coincide with the bottom face with the help of the 
bottom surface reference.

• Set the length of the line as 70 mm.
• Click OK to create the sketch and exit the sketcher window.
• Click Sketch to create the profile sketch above the Reference tab.
• Create the sketch as shown in Figure 6.23.
• Click OK to create and exit the sketch.
• Enter the pitch value of 3 mm.
• Click on the Right-handed rule icon to create the helical spring 

clockwise downward.
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FIGURE 6.23
Constructional sketch of the thread profile section for an eyebolt.

Copyrighted Material - Taylor and Francis



161Part Modeling

• Click to activate material removal.
• Click OK to create the external thread.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a rectangle of 40 mm length and 3 mm width. Place the 

rectangle such that the bottom edge of the rectangle shall coin-
cide with the straight bottom edge of the hook part and be sym-
metrical with the vertical reference line.

• Click OK to create and exit the sketch.
• Select mid plane extrusion.
• Click on the Options tab and select Through all in both depth 

selection fields.
• Click to activate the material removal option.
• Click on OK to create the extrusion.
• Save and exit the file.

6.11  Presentation

Presentation of a single CAD model is different and also very useful. The 
presentation includes excluding or hiding features, making the model trans-
parent, and so forth. Presentation of any CAD model is very important. The 
reasons are as follows:

 1. It is to be clearly understandable to manufacturing people.
 2. The process of design and affectability may need to be explained 

during verification.
 3. The component may need to be advertised for marketing and pro-

motion purposes.

The model can be presented with the following variations:

 1. Excluding features
 2. Transparency on surfaces
 3. Colors

Graphical presentation creation is discussed in detail in Chapter 12.
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6.12  Template Creation

Template creation is very useful especially when repetitive parts have some 
common features or properties like parameters, materials, and so forth. 
Template creation has the following advantages:

 1. Time saving
 2. Accuracy
 3. Use for automation

6.13  Project Work

Hands-On Exercise, Example 6.19: Creating a Paper 
Clip Handle (Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Paper Clip Handle. (Other 
names may be given, but it is advisable to provide a relevant 
name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The paper clip handle as shown in Figure 6.24 is to be created.
• Paper clip handle can be created by sweep method.
• Principally, it requires one cross-sectional sweep profile and 

sweep trajectory.
• Click on Sweep from the Model tab of the ribbon interface.
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• The sweep trajectory will be created first followed by a sweep 
operation.

• The trajectory can also be created inside the sweep operation; 
however, the sketch will not be available if the sweep feature 
is deleted.

• Select Sketch from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select the front plane as the sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
• The sketcher window will open up and the reference selection 

window appears for selection of references.
• The two references (i.e., top plane as horizontal reference and 

right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create a sketch as displayed in Figure 6.25.
• Click OK to create and exit the sketch.
• Click on Sweep from the Model tab of the ribbon interface.
• Graphically select the sketch as a trajectory.
• The system assumes the profile sketch point and shows it by 

displaying the directional arrow.
• Graphically click on the arrows of feature creation to draw the 

sweep profile in other control points.
• Click on Sketch to sketch the profile.
• The sketcher mode activates with the sketcher environment.
• Draw a circle at the intersection of references.
• Change the diameter to 2 mm.
• Click OK to create and exit the sketch.
• Click OK to finish the sweep.
• Save and exit the file.

FIGURE 6.24
3-D view of a handle of a paper clip.Copyrighted Material - Taylor and Francis



164 Computer-Aided Design

Hands-On Exercise, Example 6.20: Creating a Board 
Clip Spring (Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Board Clip spring. (Other 
names may be given, but it is advisable to provide a relevant 
name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The board clip spring as shown in Figure 6.26 is to be created.
• Click on the Helical sweep option from the drop-down menu of 

Sweep from the Model tab of the ribbon interface.
• Click on the References tab and select Define to define the helix 

sweep profile.
• Select the front plane as the sketch plane.
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FIGURE 6.25
Constructional sketch for a sweep profile of a paper clip handle.
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• The right plane shall be automatically taken as reference and 
orientation as right.

• Click on Sketch.
• The sketcher model will be activated.
• Draw a geometry centerline on the vertical reference line in the 

middle.
• Draw a vertical line at a distance of 2 mm from the vertical 

centerline.
• Set the length of the line as 8 mm.
• Click OK to create the sketch and exit the sketcher window.
• Click Sketch to create the profile sketch above the Reference tab.
• Create a circle of 1.5 mm diameter placing the center at the bot-

tom end of the vertical line.
• Click OK to create and exit the sketch.
• Enter the pitch value of 1.6 mm.
• Click on the left-handed rule icon to create the helical spring 

clockwise downward.
• Click OK to create the helical spring.
• Click on Plane from the Model tab of the ribbon interface to 

create a plane.
• Select the top plane and set the offset value to 10 mm toward 

the end of the spring.
• Click OK to create the plane.
• Select Extrude from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the newly created plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Create a line from the intersection point of the horizontal and 

vertical reference lines toward the third quadrant.
• Set the angle of 119° from the horizontal line and length of 

4 mm.
• Click OK to create and exit the sketch.
• Click on Blind extrusion and enter the depth of 3.7 mm.

FIGURE 6.26
3-D view of a board clip spring.

Copyrighted Material - Taylor and Francis



166 Computer-Aided Design

• Flip the orientation if required to make the feature in the oppo-
site direction of material removal.

• Click OK to create the extrude cut feature.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the bottom cross-sectional face of the spring profile as 

the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as bottom.
• Click on Sketch.
• The sketcher model will be activated.
• Project the circular edge of the spring profile at the bottom end.
• Click OK to create and exit the sketch.
• Click on Blind extrusion and enter the depth of 5 mm.
• Click OK to create the feature.
• Similarly, select Extrude again from the Model tab of the ribbon 

interface.
• Click on the Placement tab and Select define to define the sketch.
• Select the top cross-sectional face of the spring profile as the 

sketch plane.
• The surface shall be automatically taken as reference and ori-

entation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Project the circular edge of the spring profile at the top end.
• Click OK to create and exit the sketch.
• Click on Blind extrusion and enter the depth of 5 mm.
• Click OK to create the feature.
• Save the file and exit.

Hands-On Exercise, Example 6.21: Creating a Pulley Handle 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Pulley Handle. (Other names 
may be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit
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• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The pulley handle as shown in Figure 6.27 is to be created.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.28.
• Click OK to create and exit the sketch.
• Select mid plane extrusion.
• Enter the value 30 mm for extrusion depth.
• Click on OK to create the extrusion.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.

FIGURE 6.27
3-D view of a pulley handle.
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FIGURE 6.28
Constructional sketch of a pulley handle.
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• Select the front face as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Create a circle of diameter 50 mm at the center of the large arc.
• Click OK to create and exit the sketch.
• Click on the Material removal icon to make the extrude cut.
• Flip the orientation of extrusion if required.
• Click on the Through all option to make the cut through all the 

available depth.
• Click OK to create the extrude cut feature.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front face as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Create a circle of diameter 20 mm at the center of the small arc.
• Click OK to create and exit the sketch.
• Click on Blind extrusion and enter the depth of 100 mm.
• Flip the orientation if required to make the feature in the oppo-

site direction of material removal.
• Click OK to create the extrude cut feature.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front face as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Create the sketch as shown in Figure 6.29.
• Click on the Material removal icon to make the extrude cut.
• Flip the orientation of extrusion if required.
• Click on the blind depth option and enter the value of 10 mm 

to depth.
• Click OK to create the extrude cut feature.
• Click on Round feature from the Model tab of the ribbon interface.
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FIGURE 6.29
Constructional sketch for material removal of a pulley handle.
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• Set the value of fillet to 5 mm.
• Select all four internal edges of the newly created feature.
• Click OK to create the feature.
• Select both the lastly created blind extruded cut and round fea-

ture from the model tree by pressing the Control key on the 
keyboard.

• Right-click and select Group to make both the features in a group.
• Select Group and select Mirror from the Model tab of the ribbon 

interface.
• Select the front plane as the mirror plane.
• Click on OK to create the mirrored feature.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the front face as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Create the sketch as shown in Figure 6.30.
• Click on the Material removal icon to make the extrude cut.
• Flip the orientation of extrusion if required.
• Click on the Through all option to create the cut feature through 

all the available material depth.
• Click OK to create the extrude cut feature.
• Click on Round feature from the Model tab of the ribbon interface.
• Set the value of fillet to 3 mm.
• Select all three internal edges of the newly created feature.
• Click OK to create the feature.
• Click on the auto round feature from the Model tab of the rib-

bon interface.
• Set the value of fillet to 3 mm.
• Click OK to create the feature.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front face as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
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FIGURE 6.30
Constructional sketch for material removal through all features of a pulley handle.
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• Create the sketch as shown in Figure 6.31.
• Click on the Material removal icon to make the extrude cut.
• Flip the orientation of extrusion if required.
• Click on the Through all option to create the cut feature through 

all the available material depth.
• Click OK to create the extrude cut feature.
• Save and exit the file.

Hands-On Exercise, Example 6.22: Creating a Fan Blade 
(Software Used: Creo Parametric)

Fan blade shapes are largely varied depending on the type of fan and 
fan manufacturer. An example of fan blade creation of an industrial fan 
blade is shown here.

Steps:

• Create a part file and rename it as Fan Blade Profile. (Other 
names may be given, but it is advisable to provide a relevant 
name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The fan blade as shown in Figure 6.32 is to be created.
• A fan blade can be created by blend operation method.
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FIGURE 6.31
Constructional sketch for a keyway of a pulley handle.
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• Principally, it requires cross-sectional profiles.
• The sketches can be created during the blend operation or 

before the blend operation.
• It is preferable to create all the sketches before blend opera-

tion since any cancellations of blend operation during creation 
always cancel all the sketches if created during blend operation.

• Create a sketch file and rename it as Fan Blade Profile. (Other 
names may be given, but it is advisable to provide a relevant 
name.)

• Click OK to create the sketch file.
• The sketcher mode will be activated in the sketch file.
• Create the sketch as shown in Figure 6.33.
• Save and exit the sketch file.

FIGURE 6.32
3-D view of a fan blade.
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FIGURE 6.33
Constructional sketch of a fan blade.
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• Select the front plane from the model tree and click on Pattern 
from the Model tab of the ribbon interface.

• Select direction for creation type.
• Select the z-axis of the coordinate system as the direction.
• Enter the number of patterned components as 4 and interval 

distance 500 mm.
• Click OK to create all patterned features.
• Click on Sketch from the Model tab of the ribbon interface.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• In the sketcher ribbon interface, click on the file system to get 

data (i.e., sketch that we created in a separate file).
• Select the newly created sketch file Fan Blade Profile from the 

saved folder.
• Click OK to place the sketch.
• Resize options will appear in the ribbon interface.
• Enter 0° in the field rotational angle and scale value 1.
• Place it anywhere in the geometry.
• Click on the coincident constrain option from the sketch.
• Click on the center point of the large arc and horizontal refer-

ence line.
• Click on the center point of the large arc and vertical reference line.
• Click OK to create and exit the sketch.
• Click on Sketch again from the Model tab of the ribbon interface.
• Select plane DTM1 (first component of patterned feature) as the 

sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• In the sketcher ribbon interface, click on the file system to get 

data (i.e., sketch that we created in a separate file).
• Select the newly created sketch file Fan Blade Profile from the 

saved folder.
• Click OK to place the sketch.
• Resize options will appear in the ribbon interface.
• Enter 2.5° in the field rotational angle and scale value 0.8.
• Place it anywhere in the geometry.
• Click on the coincident constrain option from the sketch.
• Click on the center point of the large arc and horizontal refer-

ence line.
• Click on the center point of the large arc and vertical reference line.
• Draw a centerline by selecting two center points of end arcs.
• Provide an angular dimension by selecting the centerline and 

horizontal reference line.
• Enter the value 2.5° as the angular dimension.
• Click OK to create and exit the sketch.
• Click on Sketch again from the Model tab of the ribbon interface.
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• Select plane DTM2 (first component of patterned feature) as the 
sketch plane.

• The right plane shall be automatically taken as reference and 
orientation as right.

• Click on Sketch.
• In the sketcher ribbon interface, click on the file system to get 

data (i.e., sketch that we created in a separate file).
• Select the newly created sketch file Fan Blade Profile from the 

saved folder.
• Click OK to place the sketch.
• Resize options will appear in the ribbon interface.
• Enter 5° in the field rotational angle and scale value 0.75.
• Place it anywhere in the geometry.
• Click on the coincident constrain option from the sketch.
• Click on the center point of the large arc and horizontal refer-

ence line.
• Click on the center point of the large arc and vertical reference line.
• Draw a centerline by selecting two center points of end arcs.
• Provide an angular dimension by selecting the centerline and 

horizontal reference line.
• Enter the value 5° as the angular dimension.
• Click OK to create and exit the sketch.
• Click on Sketch again from the Model tab of the ribbon interface.
• Select plane DTM3 (first component of patterned feature) as the 

sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• In the sketcher ribbon interface, click on the file system to get 

data (i.e., sketch that we created in a separate file).
• Select the newly created sketch file Fan Blade Profile from the 

saved folder.
• Click OK to place the sketch.
• Resize options will appear in the ribbon interface.
• Enter 7.5° in the field rotational angle and scale value 0.7.
• Place it anywhere in the geometry.
• Click on the coincident constrain option from the sketch.
• Click on the center point of the large arc and horizontal refer-

ence line.
• Click on the center point of the large arc and vertical reference line.
• Draw a centerline by selecting two center points of end arcs.
• Provide an angular dimension by selecting the centerline and 

horizontal reference line.
• Enter the value 7.5° as the angular dimension.
• Click OK to create and exit the sketch.
• Click on Blend from the Model tab of the ribbon interface.
• Click on the Sections tab.
• Select the option Selected sections.
• Select the first sketch.
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• Click on Insert.
• Select the second sketch.
• Click on Insert.
• Select the third sketch.
• Click on Insert.
• Select the fourth sketch.
• Click OK to create the feature.
• Click Plane from the Model tab of the ribbon interface.
• A plane creation window appears.
• Select the front plane and enter an offset value of 200 mm to 

create the plane opposite to the blend feature side.
• Click on Axis from the Model tab of the ribbon interface.
• Select the lastly created plane and front plane.
• Click on OK to create the axis.
• Click on Extrude from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the front face as the sketch plane.
• The top plane shall be automatically taken as reference and ori-

entation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Select the lastly created axis as reference and small-end per-

pendicular surface of the blend feature.
• Create a circle placing the center point in the axis.
• Click on Tangent constrain from the Sketcher tab of the ribbon 

interface.
• Select the circle and the surface reference of the small-end per-

pendicular surface.
• Click OK to create and exit the sketch.
• Click on the Material removal icon to make the extrude cut.
• Flip the orientation of extrusion if required.
• Click on the Through all option to make the cut through all the 

available depth.
• Click on the Options tab.
• Click on the drop-down menu on the other side of the depth 

option and select Through all.
• Click OK to create the extrude cut feature.
• Save and exit the file.

Hands-On Exercise, Example 6.23: Spiral 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Spiral. (Other names may be 
given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.
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• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The spiral as shown in Figure 6.34 is to be created.
• A spiral can be created by many methods, for example, creat-

ing a horizontal helix path, but it also depends on the software.
• Click on the drop-down menu of datum from the model of the 

ribbon interface.
• Click on the curve from the equation.
• Select the coordinate system Cartesian.
• Click on Equation to create the equation.
• Write the following:

• n = 4*t
• a = 5*t
• x = n*cos(a*360)
• z = n*sin(a*360)
• y = 0

• Click OK to create the equation.
• Click on the Reference tab.
• Select the available default coordinate system.
• Enter 0.20 in the From field and 1.00 in the To field.
• Click OK to create the spiral curve.
• Click on Sweep from the Model tab of the ribbon interface.
• Graphically select the sketch as a trajectory.

FIGURE 6.34
3-D view of a spiral.
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• The system assumes the profile sketch point and shows it by 
displaying the directional arrow.

• Graphically click on the arrows of feature creation to draw the 
sweep profile in other control points.

• Click on Sketch to sketch the profile.
• The sketcher mode activates with the sketcher environment.
• Draw a circle at the intersection of references.
• Change the diameter to 0.5 mm.
• Click OK to create and exit the sketch.
• Click OK to finish the sweep.
• Save and exit the file.

Hands-On Exercise, Examples 6.24: User-Defined Parameter—
Cost of Tank Shell (Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Tank_shell. (Other names 
may be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The model as shown in Figure 6.35 is to be created.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the top plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a circle of diameter 500 mm.
• Click OK to create and exit the sketch.
• Select Blind extrusion.
• Enter the value 1000 mm for extrusion depth.
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• Click on the Thicken part creation option and enter the value 
of 10 mm.

• Click on OK to create the extrusion.
• Click on File > Prepare > Model properties.
• Click on Material change to change the material.
• Double-click on Steel to set steel as the material.
• Click Close at the bottom to close the model properties window.
• Click on the Analysis tab of the ribbon interface.
• Click on Mass properties.
• The mass properties analysis window will appear.
• Click on Preview in the mass properties analysis window 

or middle-click on the mouse button to calculate the mass 
properties.

• Mass properties will show in the mass properties box.
• In the bottom of the mass properties window, click on the 

drop-down menu and select Feature to create the analysis as 
a feature.

• The analyzed mass properties are saved as a feature and dis-
played in the model tree.

• Click on the Tools tab in the ribbon interface.
• Click on Parameters.
• The parameters window will appear.
• Add a parameter and rename it as cost_per_tonne.
• Keep the type as real number.
• Enter the cost_per_tonne parameter value as 40000.
• Click on Relation from the Tools tab of the ribbon interface.
• Click on Feature in the Look in box on the top.
• Select the feature lastly added in the analyzed mass properties.
• The parameter mass is displayed in the parameter area in the 

bottom of the relation window.
• Right-click on the parameter mass and select Insert to relation.
• The mass will appear in the relation window.
• Click in the front of the mass in the relation window and write 

down “Total_Material_Cost = cost_per_tonne*MASS.”

FIGURE 6.35
View of a shell of a tank.Copyrighted Material - Taylor and Francis
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• Click on Verify on the upper right side of the relation window.
• A notification box with a message “Relations have been suc-

cessfully verified” should appear.
• Click OK to close the box.
• A parameter of Total_Material_Cost shall have been added in 

the parameter window displaying the total material cost.
• Click OK in the bottom section of the relation window to close 

the window.
• Save and exit the file.

Hands-On Exercise, Example 6.25: User-Defined Parameter—
Paint of Tank Outer Surface (Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as User_defined_paint. (Other 
names may be given, but it is advisable to provide a relevant 
name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The model as shown in Figure 6.36 is to be created.
• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Thicken part creation option and enter the value 

of 10 mm.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as per Figure 6.37.
• Click OK to create and exit the sketch.
• Select Blind revolve.
• Enter the value 360 mm for revolving angle.
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• Click on OK to create the revolve feature.
• Click on the Analysis tab of the ribbon interface.
• Click on the drop-down menu of summary and select Area.
• Measure: The area analysis window will appear.
• Select all the outer surfaces one by one by pressing the Control 

key on the keyboard.
• The total area will be displayed in the result box.
• In the top of the measure area window, click on the drop-down 

menu and select Make feature to create the analysis as a feature.
• The analyzed measure of area is saved as a feature and dis-

played in the model tree.
• Click on Relation from the Tools tab of the ribbon interface.
• Click on Feature in the Look in box on the top.
• Select the feature lastly added in the analyzed measure area.
• The parameter Total_area is displayed in the parameter area in 

the bottom of the relation window.

FIGURE 6.36
View of the outer surface of a tank.
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FIGURE 6.37
Constructional sketch of a tank.
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• Right-click on the parameter mass and select Insert to relation.
• The mass will appear in the relation window.
• Click in the front of the mass in the relation window and write 

down “Total_Material_Cost = cost_per_tonne*MASS.”
• Click on Verify on the upper right side of the relation window.
• A notification box with a message “Relations have been suc-

cessfully verified” should appear.
• Click OK to close the box.
• A parameter of Total_Material_Cost shall have been added in 

the parameter window displaying the total material cost.
• Add a parameter and rename it as Primer_coat.
• Keep the change as integer.
• Enter the Primer_coat parameter value as 1.
• Add a parameter and rename it as Paint_coat.
• Keep the change as integer.
• Enter the Paint_coat parameter value as 3.
• Add a parameter and rename it as Primer_area_per_Liter.
• Keep the change as real number.
• Enter the Primer_area_per_Liter parameter value as 10.
• Add a parameter and rename it as Paint_area_per_Liter.
• Keep the change as real number.
• Enter the Paint_area_per_Liter parameter value as 9.
• In the relation area, write down the following:

• Total_primer_liter = ((TOTAL_AREA/1000000)/Primer_ 
area_per_liter)*Primer_coat

• Total_paint_liter = ((TOTAL_AREA/1000000)/Paint_area_ 
per_liter)*Paint_coat

• Note: Total area is divided by 1,000,000 to obtain the area 
in square meters.

• Click on Verify on the upper right side of the relation window.
• A notification box with a message “Relations have been suc-

cessfully verified” should appear.
• Click OK to close the box.
• Notice that two parameters, that is, Total_primer_liter and 

Total_paint_liter, have been added showing the requirement of 
primer and paint in liters.

• Click OK in the bottom section of the relation window to close 
the window.

• Save and exit the file.

Hands-On Exercise, Example 6.26: Creating a Knob 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Knob. (Other names may be 
given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.
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• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The knob as shown in Figure 6.38 is to be created.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a circle of diameter 50 mm.
• Click OK to create and exit the sketch.
• Select mid plane extrusion.
• Enter the value 2 mm for extrusion depth.
• Click on OK to create the extrusion.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the top face of the extruded feature as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.

FIGURE 6.38
3-D view of a knob.
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• Create the sketch as shown in Figure 6.39.
• Click OK to create and exit the sketch.
• Click on the Material removal icon to make the extrude cut.
• Flip the orientation of extrusion if required.
• Click on the Through all option to make the cut through all the 

available depth.
• Click OK to create the extrude cut feature.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Select the top face as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Select the icon Project to project the entities.
• Select Loop for the projected entities creation option.
• Select the top surface; it will select the outer profile.
• Click OK to create and exit the sketch.
• Click on Blind extrusion and enter the depth of 20 mm.
• Flip the orientation if required to make the feature in the oppo-

site direction of material removal.
• Click on the Thicken option and set the thickness as 2 mm.
• Flip the orientation outward.
• Click OK to create the extrude feature.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the bottom face of the first extrusion as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
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FIGURE 6.39
Constructional sketch of a knob.
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• Draw a circle placing the center in the intersection of the hori-
zontal and vertical refereces.

• Enter 20 mm as the diameter.
• Click OK to create and exit the sketch.
• Flip the orientation of extrusion if required.
• Click on the blind depth option and enter the value of 18 mm 

to depth.
• Click on the Thicken option and set the thickness as 2 mm.
• Flip the orientation inward.
• Select Extrude again from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the bottom face of the lastly created extrusion as the 

sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Create a rectangle of dimensions 20 × 5 mm keeping the hori-

zontal hands at 20 mm.
• Place the rectangle symmetric to the horizontal and vertical ref-

erence lines.
• Click OK to create and exit the sketch.
• Select the Material removal icon to create the extrude cut feature.
• Flip the orientation of extrusion if required.
• Click on the blind depth option and enter the value of 5 mm to 

depth.
• Click on Round feature from the Model tab of the ribbon 

interface.
• Set the value of fillet to 1 mm.
• Select the internal curved edges by pressing the Control key for 

multiple selections.
• Click OK to create the feature.
• Click on Round feature again from the Model tab of the ribbon 

interface.
• Set the value of fillet to 3 mm.
• Select the external curved edge at top face of the extrusions.
• Click OK to create the feature.

Hands-On Exercise, Example 6.27: Creating a Collet 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Collet. (Other names may be 
given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.
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• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The collet as shown in Figure 6.40 is to be created.
• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.41.

FIGURE 6.40
3-D view of a collet.
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FIGURE 6.41
Constructional sketch of a collet.
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• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click on OK to create the revolve feature.
• Select Extrude from the Model tab of the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the left face of the extruded feature as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Create a rectangle of 1 mm width starting from the horizontal 

reference line and ending beyond the circle.
• The rectangle shall be placed symmetrically about the vertical 

reference line.
• A vertical centerline on the vertical reference line is required to 

place the rectangle symmetrical to the vertical reference line.
• Click OK to create and exit the sketch.
• Click on the Material removal icon to make the extrude cut.
• Flip the orientation of extrusion if required.
• Enter the depth of cut as 48 mm.
• Select the lastly created extrude feature from the model tree.
• Right-click and select Pattern.
• Select Axis on the type pattern selection box.
• Select the revolved axis.
• Enter the value 6.
• Make sure to activate the equally spaced option on a 360° rota-

tional angle.
• Click OK to create the pattern of the extrude cut feature.
• Similarly, select Extrude again from the Model tab of the ribbon 

interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the right face of the extruded feature as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Create the sketch as displayed in Figure 6.42.
• Click OK to create and exit the sketch.
• Click on the Material removal icon to make the extrude cut.
• Flip the orientation of extrusion if required.
• Enter the depth of cut as 48 mm.
• Select the lastly created extrude feature from the model tree.
• Right-click and select Pattern.
• Select Axis on the type pattern selection box.
• Select the revolved axis.
• Enter the value 6.
• Make sure to activate the equally spaced option on a 360° rota-

tional angle.
• Click OK to create the pattern of the extrude cut feature.
• Save and exit the file.
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Hands-On Exercise, Example 6.28: Creating a Cap 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Cap. (Other names may be 
given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The cap as shown in Figure 6.43 is to be created.
• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the 

sketch.
• Activate the thin feature option.
• Enter the thickness as 2 mm.
• Select the front plane as the sketch plane.
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FIGURE 6.42
Constructional sketch for a material removal operation in the creation of a 3-D model of a 
collet.
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• The right plane shall be automatically taken as reference and 
orientation as right.

• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.44.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click on OK to create the revolve feature.
• Click on Round feature from the Model tab of the ribbon interface.
• Create the fillet as shown in Figure 6.45.
• Click OK to create the feature.

• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the bottom face plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Project the outside circular edge.
• Click OK to create and exit the sketch.
• Select thin extrusion.

FIGURE 6.43
3-D view of a cap.
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FIGURE 6.44
Constructional sketch of a cap.
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• Set the value as 1 mm.
• Flip the orientation of material thickness inward.
• Enter the value 2 mm for extrusion depth.
• Slip the feature creation orientation toward the body of the cap.
• Click on OK to create the extrusion.

• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the inside groove face plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Project the inside circular edge of the groove.
• Click OK to create and exit the sketch.
• Select thin extrusion.
• Set the value as 1 mm.
• Flip the orientation of material thickness outward.
• Enter the value 3 mm for extrusion depth.
• Slip the feature creation orientation downward.
• Click on OK to create the extrusion.
• Click on Round feature from the Model tab of the ribbon interface.
• Set the value of fillet to 0.5 mm.
• Select two outward edges of the newly created extrusion.
• Click OK to create the feature.

• Click on the Helical sweep option from the drop-down menu of 
Sweep from the Model tab of the ribbon interface.

• Click on the References tab and select Define to define the helix 
sweep profile.

• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.

1.00

FIGURE 6.45
Constructional sketch for a material removal operation of a cap.
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• Draw a geometry centerline on the vertical reference line in the 
middle.

• Draw a vertical line at the right-hand inside edge by taking the 
reference of the cylindrical surface. The line should start 1 mm 
above the bottom horizontal surface.

• Set the length of the line as 7 mm.
• Click OK to create the sketch and exit the sketcher window.
• Click Sketch to create the profile sketch above the Reference tab.
• Draw a half circle of diameter 1.5 mm placing the center at the 

intersection of reference lines.
• Click OK to create and exit the sketch.
• Enter the pitch value of 3 mm.
• Click on the Right-handed rule icon to create the helical spring 

clockwise downward.
• Click OK to create the thread.

• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the top surface of the bottom extrusion as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as shown in Figure 6.46.
• Click OK to create and exit the sketch.
• Flip the material orientation upward.
• Enter the value 11 mm for extrusion depth.
• Click on OK to create the extrusion.

• Click on Round feature from the Model tab of the ribbon 
interface.

• Set the value of fillet to 0.5 mm.
• Select the side and top edges of the last extrude.
• Click OK to create the feature.

11.00
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FIGURE 6.46
Constructional sketch of a feature in the creation of 3-D model of a cap.
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• Select the last extrusion and round feature from the model tree 
by keeping the Control key pressed.

• Select the newly created group in the model tree.
• Right-click and select Pattern.
• Select Axis in the Type of pattern selection field.
• Select the central axis.
• Enter the quantity 24 for patterned feature.
• Select the option to make the pattern equally spaced within 360°.
• Click OK to create the patterned feature.
• Save and exit the file.

Hands-On Exercise, Example 6.29: Creating an 
Industrial Hook (Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Industrial hook. (Other names 
may be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The industrial hook as shown in Figure 6.47 is to be created.

FIGURE 6.47
3-D view of an industrial hook.
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• Click on Sweep from the Model tab of the ribbon interface.
• The sweep trajectory will be created first followed by a sweep 

operation.
• The trajectory can also be created inside the sweep operation; 

however, the sketch will not be available if the sweep feature 
is deleted.

• Select Sketch from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select the front plane as the sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
• The sketcher window will open up and the reference selection 

window appears for selection of references.
• The two references (i.e., top plane as horizontal reference and 

right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create a sketch as displayed in Figure 6.48.
• Click OK to create and exit the sketch.
• Click Datum plane on the Model tab from the ribbon interface.
• Select any end point of the curve and the adjacent curve by 

pressing the Control key.
• Set the end point reference as Through and curve as Normal. 

This will allow creation of a plane perpendicular to the curve 
at the end point.

• Similarly, click Datum plane again on the Model tab from the 
ribbon interface.

• Select the other end point of the curve and the adjacent curve 
by pressing the Control key.

• Set the end point reference as Through and curve as Normal. 
This will allow creation a plane perpendicular to the curve at 
the end point.

• Select Sketch from the Model tab of the ribbon interface.
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FIGURE 6.48
Constructional sketch of an industrial hook.
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• A sketch window for selection of sketch plane will appear.
• Select the top plane as the sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
• The sketcher window will open up and the reference selection 

window appears for selection of references.
• The two references (i.e., top plane as horizontal reference and 

right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create a sketch as displayed in Figure 6.49.
• Click OK to create and exit the sketch.
• Select Sketch again from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select the right plane as the sketch plane.
• The top plane shall automatically be selected as reference and 

the orientation is to be top.
• Click on Sketch.
• The sketcher window will open up and the reference selection 

window appears for selection of references.
• The two references (i.e., top plane as horizontal reference and 

right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create the sketch as displayed in Figure 6.50.
• Click OK to create and exit the sketch.
• Select Sketch again from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select the top plane as the sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
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FIGURE 6.49
Constructional sketch of the profile of an industrial hook.
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• The sketcher window will open up and the reference selection 
window appears for selection of references.

• The two references (i.e., top plane as horizontal reference and 
right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create an oblong hole of diameter 15 mm and center-to-center 
distance 5 mm. Pierce the origin of the top arc center to the curve.

• Click OK to create and exit the sketch.
• Select Sketch again from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select the newly created angular plane as the sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
• The sketcher window will open up and the reference selection 

window appears for selection of references.
• The two references (i.e., top plane as horizontal reference and 

right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create a hole of diameter 15 mm. Pierce the origin of top arc 
center to the curve.

• Break the circle into four equal segments by creating center-
lines from the origin at an angle 45° to the horizontal or vertical 
reference line.

• Click OK to create and exit the sketch.
• Select Sketch again from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select the newly created plane that is parallel to the top plane 

as the sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
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FIGURE 6.50
Constructional sketch of the profile of an industrial hook.
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• The sketcher window will open up and the reference selection 
window appears for selection of references.

• The two references (i.e., top plane as horizontal reference and 
right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create a hole of diameter 15 mm. Pierce the origin of top arc 
center to the curve.

• Break the circle into four equal segments by creating center-
lines from the origin at an angle 45° to the horizontal or vertical 
reference line.

• Click OK to create and exit the sketch.
• Click on Sweep blend from the Model tab of the ribbon interface.
• Click on the Reference tab.
• Graphically select the first sketch as a trajectory.
• The system assumes the profile sketch point and shows it by 

displaying the directional arrow.
• Keep the section plane control as normal to trajectory.
• Click on the Sections tab.
• Select Selected sections.
• Select all the sections one by one starting from top by clicking 

the inset button.
• Make sure the start point shall be in the same quadrant for all 

the sections.
• Click OK to create the swept blend feature.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the top face of the swept blend feature as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a circle by projecting the circular edge.
• Click OK to create and exit the sketch.
• Enter the value 50 mm for extrusion depth.
• Click on OK to create the extrusion.
• Click on the Helical sweep option from the drop-down menu of 

Sweep from the Model tab of the ribbon interface.
• Click on References tab and select Define to define the helix 

sweep profile.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a geometry centerline on the vertical reference line in the 

middle.
• Draw a vertical line at the right-hand edge by taking the ref-

erence of the cylindrical surface. The line should start 5 mm 
below the top horizontal surface.
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• Set the length of the line as 36 mm.
• Click OK to create the sketch and exit the sketcher window.
• Click Sketch to create the profile sketch above the Reference tab.
• Create a square of 2 × 2 mm placing the left edge of the square 

at the vertical reference line and symmetric to the horizontal 
line.

• Click OK to create and exit the sketch.
• Enter the pitch value of 4 mm.
• Click on the Right-handed rule icon to create the helical spring 

clockwise downward.
• Click OK to create the thread.

Hands-On Exercise, Example 6.30: Creating a Multistart Thread 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Multistart thread. (Other 
names may be given, but it is advisable to provide a relevant 
name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The multistart thread as shown in Figure 6.51 is to be created.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a circle of diameter 20 mm.
• Click OK to create and exit the sketch.
• Enter the value 200 mm for extrusion depth.
• Click on OK to create the extrusion.
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• Click on the Helical sweep option from the drop-down menu of 
Sweep from the Model tab of the ribbon interface.

• Click on References tab and select Define to define the helix 
sweep profile.

• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a geometry centerline on the vertical reference line in the 

middle.
• Draw a vertical line at the right-hand edge by taking the ref-

erence of the cylindrical surface. The line should start 10 mm 
below the bottom horizontal surface and end 10 mm above the 
top horizontal surface.

• Click OK to create the sketch and exit the sketcher window.
• Click Sketch to create the profile sketch above the Reference tab.
• Create a square of 2 × 2 mm placed in the second quadrant.
• Click OK to create and exit the sketch.
• Enter the pitch value of 12 mm.
• Click on the Right-handed rule icon to create the helical spring 

clockwise downward.
• Click OK to create the thread.
• Select the helical sweep in the model tree.
• Right-click and select Pattern.
• Select Axis in the Type of pattern selection field.
• Select the central axis.
• Enter the quantity 3 for patterned feature.
• Select the option to make the pattern equally spaced within 360°.
• Click OK to create the patterned feature.
• Save and exit the file.

FIGURE 6.51
3-D view of a multistart thread.
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Hands-On Exercise, Example 6.31: Creating a Spanner 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Spanner. (Other names may 
be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new Solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The spanner as shown in Figure 6.52 is to be created.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as shown in Figure 6.53.
• Click OK to create and exit the sketch.
• Select mid plane extrusion.
• Enter the value 4 mm for extrusion depth.
• Click on OK to create the extrusion.

• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.

FIGURE 6.52
3-D view of a spanner.
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• The right plane shall be automatically taken as reference and 
orientation as right.

• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as shown in Figure 6.54.
• Click OK to create and exit the sketch.
• Select mid plane extrusion.
• Enter the value 2 mm for extrusion depth.
• Click on OK to create the extrusion.

• Click on Round feature from the Model tab of the ribbon interface.
• Set the value as required for the edges shown in Figure 6.54.
• Select the edges as displayed in Figure 6.55.
• The fillets may need to be created by individual fillet operation.
• Click OK to create the feature.
• Save and exit the file.
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FIGURE 6.53
Constructional sketch of a spanner.
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FIGURE 6.54
Constructional sketch of features of a spanner.
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FIGURE 6.55
View of edges for round operation of a spanner.
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Hands-On Exercise, Example 6.32: Creating a Screwdriver 
(Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Screwdriver. (Other names 
may be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The screwdriver as shown in Figure 6.56 is to be created.
• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.

FIGURE 6.56
3-D view of a screwdriver.
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200 Computer-Aided Design

• The right plane shall be automatically taken as reference and 
orientation as right.

• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.57.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click on OK to create the revolve feature.

• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.58.
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FIGURE 6.57
Constructional sketch of a screwdriver.
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FIGURE 6.58
Constructional sketch of features of a screwdriver.
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• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Select the material removal option.
• Click on OK to create the revolve feature.

• Select Sketch from the Model tab of the ribbon interface.
• A sketch window for selection of sketch plane will appear.
• Select the front plane as the sketch plane.
• The right plane shall automatically be selected as reference and 

the orientation is to be right.
• Click on Sketch.
• The sketcher window will open up and the reference selection 

window appears for selection of references.
• The two references (i.e., top plane as horizontal reference and 

right plane as vertical reference) shall be automatically taken; 
however, if not, please select the same.

• Create a sketch as displayed in Figure 6.59.
• Click OK to create and exit the sketch.

• Click on Round feature from the Model tab of the ribbon interface.
• Set the value of chamfer to 0.5 mm (D X D).
• Select all bottom circular edges.
• Click OK to create the feature.

• Click on Sweep from the Model tab of the ribbon interface.
• Select the sketch as sweep trajectory.
• Click on Sweep from the Model tab of the ribbon interface.
• Graphically select the sketch as a trajectory.
• The system assumes the profile sketch point and shows it by 

displaying the directional arrow.
• Graphically click on the arrows of feature creation to draw the 

sweep profile in other control points.
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FIGURE 6.59
Constructional sketch of features of a screwdriver.
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• Click on Sketch to sketch the profile.
• The sketcher mode activates with the sketcher environment.
• Draw the sketch as shown in Figure 6.60.
• Click OK to create and exit the sketch.
• Select the material removal option.
• Click OK to finish the sweep.

• Click on Round feature from the Model tab of the ribbon interface.
• Set the value of fillet to 0.5 mm.
• Select all two intermediate circular edges of the newly created 

feature.
• Click OK to create the feature.

• Click Ok datum plane from the Model tab of the ribbon interface.
• Select the top face as the reference plane.
• Set the offset value 10 mm downward.
• Click OK to create the datum plane.

• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the newly created plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.61.
• Click OK to create and exit the sketch.
• Enter the value 15 mm for extrusion depth.
• If required, flip the material orientation to make the cut downward.
• Select the material removal option.
• Click on OK to create the extrusion.
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FIGURE 6.60
Constructional sketch of features of a screwdriver.
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• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the surface created by the last extrusion cut as the sketch 

plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.62.
• Click OK to create and exit the sketch.
• Select the Up to surface option.
• Select the opposite cut surface of the same side.
• Click on OK to create the extrusion.
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FIGURE 6.61
Constructional sketch of features of a screwdriver.
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FIGURE 6.62
Constructional sketch of features of a screwdriver.
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• Click on Round feature from the Model tab of the ribbon interface.
• Set the value of fillet to 0.5 mm.
• Select all two external straight edges of the lastly created 

extrusion.
• Click OK to create the feature.
• Save and exit the file.

Hands-On Exercise, Example 6.33: Creating a Plastic 
Bottle (Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Plastic bottle. (Other names 
may be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.

• The plastic bottle as shown in Figure 6.63 is to be created.

FIGURE 6.63
3-D view of a plastic bottle.
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• Select the Blend feature from the ribbon at the top. Clicking on 
the feature opens the selection box for all other options.

• You may change the name of the feature to be created; it helps 
to trace back the feature in the future so that one easily can 
understand which feature is used where.

• Click on the References tab and select Sketched feature.
• Click on Define, select the top plane as the sketch plane, and 

click on Sketch.
• The horizontal and vertical references are to be taken automati-

cally by the system.
• Draw a rectangle of dimensions 60 × 60 mm symmetric to the 

horizontal and vertical centerline.
• Click OK to finish the sketch.
• Click Insert to sketch another section and provide 15 as the off-

set from the secion1 option (offset dimension option).
• Click on Sketch to sketch a circle.
• The horizontal and vertical references are to be taken automati-

cally by the system.
• Draw a circle placing the center point of the circle at the inter-

section of the horizontal and vertical reference lines.
• Make the diameter of the circle 46 mm.
• Draw two centerlines at an angle 45° to the horizontal and verti-

cal reference lines.
• Break the circle into four parts at the intersection of centerlines.
• Click OK to finish the sketch.
• Click OK to create the blend feature.
• Click on Round feature from the Model tab of the ribbon interface.
• Set the value of fillet to 5 mm.
• Select all four inclined edges of the newly created feature.
• Click OK to create the feature.

• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the bottom surface as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Project the outer edges of the bottom surface.
• Click OK to create and exit the sketch.
• Select the extrusion downward.
• Enter the value 210 mm for extrusion depth.
• Click on OK to create the extrusion.

• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the top surface as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
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• The sketcher model will be activated.
• Project the outer edges of the top surface.
• Click OK to create and exit the sketch.
• Select the extrusion upward.
• Enter the value 20 mm for extrusion depth.
• Click on OK to create the extrusion.

• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.64.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click on the material removal option.
• Click on OK to create the revolve feature.

• Click Ok datum plane from the Model tab of the ribbon interface.
• Select the top plane as the reference plane.
• Set the offset value 15 mm downward.
• Click OK to create the datum plane.

• Click Shell from the Model tab of the ribbon interface.
• Set the shell thickness as 1 mm.
• Select the top circular flat surface to remove and create the bot-

tle opening.
• Click OK to create the shell feature.

• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
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FIGURE 6.64
Constructional sketch of features of a plastic bottle.
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• Select the lastly created datum plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.65.
• Click OK to create and exit the sketch.
• Select the extrusion downward.
• Enter the value 180 mm for extrusion depth.
• Click on OK to create the extrusion.

• Click on Round feature from the Model tab of the ribbon 
interface.

• Set the value of fillet to 1.5 mm.
• Select all two circular outside boundary edges of the newly cre-

ated feature.
• Click OK to create the feature.

• Click on Round feature from the Model tab of the ribbon 
interface.

• Set the value of fillet to 2 mm.
• Select all outside boundary edges of the newly created feature.
• Click OK to create the feature.

• Select the two lastly created rounds and extrusions by pressing 
the Control key.

• Right-click and select Group.

• Right-click on the group and select Pattern.
• Select the direction in the pattern type selection field.
• Select the right plane for pattern direction.
• Set the value of 5 instances at 10 mm distance toward the right 

plane.
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FIGURE 6.65
Constructional sketch of features of a plastic bottle.
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• Click OK to create the patterned feature.
• Similarly, repeat the aforementioned steps to create the extru-

sion and round feature in the other three sides.

• Click on Round feature from the Model tab of the ribbon interface.
• Set the value of fillet to 3 mm.
• Select all four bottom edges and four top edges of the bottle 

body.
• Click OK to create the feature.
• Click on Round feature from the Model tab of the ribbon 

interface.
• Set the value of fillet to 7 mm.
• Select the circular edge at the bottom revolve.
• Click OK to create the feature.

• Click on Revolve from the Model tab in the ribbon interface.
• Click on the thin feature option.
• Set the value 1 mm for thin revolve.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.66.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click on OK to create the revolve feature.

• Click on Round feature from the Model tab of the ribbon interface.
• Set the value of fillet to 0.5 mm.
• Select all two external circular edges of the newly created feature.
• Click OK to create the feature.
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FIGURE 6.66
Constructional sketch of features of a plastic bottle.
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• Click on the Helical sweep option from the drop-down menu of 
Sweep from the Model tab of the ribbon interface.

• Click on the References tab and select Define to define the helix 
sweep profile.

• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a geometry centerline on the vertical reference line in the 

middle.
• Draw a vertical line at the right-hand edge by taking the ref-

erence of the cylindrical surface. The line should start 3 mm 
below the top horizontal surface.

• Set the length of the line as 7 mm.
• Click OK to create the sketch and exit the sketcher window.
• Click Sketch to create the profile sketch above the Reference 

tab.
• Draw a half circle of diameter 1.5 mm placing the center at the 

intersection of reference lines.
• Click OK to create and exit the sketch.
• Enter the pitch value of 3 mm.
• Click on the Right-handed rule icon to create the helical spring 

clockwise downward.
• Click OK to create the thread.

Hands-On Exercise, Example 6.34: Creating a 
Crankshaft (Software Used: Creo Parametric)

Steps:

• Create a part file and rename it as Crankshaft. (Other names 
may be given, but it is advisable to provide a relevant name.)

• Select Solid on the right-hand side of the box. This will activate 
the solid mode and environment.

• Uncheck the box of the default template and click OK to create 
a new solid file.

• The template selection box will appear.
• Select mmns_part_Solid. This will allow us to use the solid 

template file of the following units:
• mm—millimeter for length unit
• n—newton for force unit
• s—second for time unit

• Once the solid part is created, go to File > Prepare > Model 
properties to check the units. In the upper sections, the units of 
the model will be displayed.
• Note: The units usually are displayed in the summary sec-

tion of any CAD software. The setting of units usually is in 
the tools or settings.
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• The crankshaft as shown in Figure 6.67 is to be created.
• Click OK datum plane from the Model tab of the ribbon interface.
• Select the right plane as the reference plane.
• Set the offset value −50 mm downward.
• Click OK to create the datum plane.
• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as shown in Figure 6.68.
• Click OK to create and exit the sketch.
• Select mid plane extrusion.
• Enter the value 20 mm for extrusion depth.
• Click on OK to create the extrusion.
• Select the lastly created extrusion in the model tree.
• Right-click and select Pattern.
• Select direction as the pattern type.
• Select the right plane as the directional reference.
• Enter the quantity 2 for patterned feature.

FIGURE 6.67
3-D view of a crankshaft.
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FIGURE 6.68
Constructional sketch of features of a crankshaft.

Copyrighted Material - Taylor and Francis



211Part Modeling

• Flip the orientation of the pattern toward the right plane.
• Click OK to create the patterned feature.

• Click on Extrude from the Model tab in the ribbon interface.
• Click on the Placement tab and select define to define the sketch.
• Select the inside surface of the first extrusion as the sketch plane.
• The right plane shall be automatically taken as reference and 

orientation as right.
• Click on Sketch.
• The sketcher model will be activated.
• Draw a circle of diameter 30 mm.
• Place the center of the circle on the center of the small arc with 

the help of taking the small circular edge reference.
• Click OK to create and exit the sketch.
• Select the Up to the entity option for depth.
• Select the inside surface of the patterned object.
• Click on OK to create the extrusion.
• Select the lastly created datum plane, pattern, and extrusion in 

the model tree by keeping the Control key pressed.
• Right-click and select Group to make a group with these three 

features.
• Select the newly created group in the model tree.
• Right-click and select Pattern.
• Select Dimension in the Type of pattern selection field.
• Select the dimensions −50 mm and the angle 90°.
• Enter the incremental value −320 for linear dimension and 90° 

for angular dimension.
• Enter the quantity 3 for patterned feature.
• Click OK to create the patterned feature.
• Click on Revolve from the Model tab in the ribbon interface.
• Click on the Placement tab and select Define to define the sketch.
• Select the front plane as the sketch plane.
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FIGURE 6.69
Constructional sketch of features of a crankshaft.
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• The right plane shall be automatically taken as reference and 
orientation as right.

• Click on Sketch.
• The sketcher model will be activated.
• Draw the sketch as displayed in Figure 6.69.
• Click OK to create and exit the sketch.
• Ensure the revolve angle shall be 360°.
• Click on OK to create the revolve feature.
• Click on the auto round feature from the Model tab of the rib-

bon interface.
• Set the value of fillet to 3 mm.
• Click OK to create the feature.
• Save and exit the file.

QUESTIONS

 1. What is a part?
 2. Differentiate between part and feature.
 3. What are the advantages of creating features in relations?
 4. Describe the usability of patterns.
 5. Why is the draft feature required?
 6. Describe the advantages of cosmetic features.
 7. Describe the uses of datum planes.
 8. Differentiate the features blend sweep and swept blend.
 9. Describe the different types of surfaces.
 10. How are the manipulations of properties important?
 11. Describe the advantages of the use of map keys.
 12. What is parametric modeling?
 13. Site an example of the use of parametric modeling.
 14. Describe the procedure of parametric modeling.
 15. What is application-based modeling?
 16. How is application-based modeling advantageous?
 17. Why are graphical presentations important?
 18. What is a template?
 19. Describe the advantage of using templates.
 20. How are templates created?
 21. Describe the advantages of using a customized template.
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